2 Replies Latest reply on May 10, 2016 10:17 AM by contr8l

    Renders failing (RAM issue) on Windows 10


      I've been having issues with renders failing since updating to Windows 10 with the following error message:

      After Effects error: Unable to allocate enough memory to render the current frame (1280x720 @ 16bpc). Either decrease the memory requirements for rendering of this frame, or install more RAM. (12805). For more information, see www.adobe.com/go/learn_ae_mem (7 :: 66)After Effects error: Timewarp out of memory. (4) (25 :: 60)


      It failed less than half way through the render (at 01:58:22 of 04:10:00) after 2hr57 min. Also my project is set to 8bpc in project settings so why is the error saying its rendering in 16bpc (is this due to an effect)?


      Using AE version:

      AE CC2015.2 Version (I'm not using Multiprocessing, in fact I don't even see it as an option in the Preference Menu?)


      Magic Bullet Suite (12.1.4)

      Render settings:

      H264 Quicktime MOV with Audio (AAC), 100% quality, 8bpc

      PC specs:

      16GB RAM, Intel i7-4790, NVIDIA GeForce 720

      Running Windows 10 (1511) 64bit with issues, or running Windows 8.1 (6.3 Build 9600) 64bit without issues.


      Version 7.7.9


      I don't have any other applications running while using AE and rendering. The render will complete if I set the quality down to 70%, which I thought was weird because I would have assumed AE would need to store more information about each frame (and the frames either side) in order to make the compression. I've rolled back to Win 8.1 and using the same render settings, the render completed in 2hr32 with no error. I have also been able to output an uncompressed version in Quicktime Animation in 16bpc on Win 8.1 which I can't do on Win 10.


      The footage is being loaded into AE as (uncompressed) image sequences, with a DOF pass, motion blur, colour correct - so there's quite a lot of stuff happening on each frame but its consistent through out the project. What I mean is it hasn't suddenly got to an intensive frame and given up, there's no difference between the frames it failed and the rest of the project. It's nothing it shouldn't be able to handle (and it's worked on Win 8.1).


      I'm just confused as to why it would render OK on Win 8.1 but then be sluggish and fail on Win 10? And what may be a solution? It seems like an issue with the RAM not being made available again?

        • 1. Re: Renders failing (RAM issue) on Windows 10
          Rick Gerard Adobe Community Professional & MVP

          The first thing I want to say is that this is an excellently posed question. Thank you.


          I'm pretty sure that your AE is up to date but check to make sure. I'm on a Mac so right now our build numbers are different. There is no Multi Processing in CC 2015 because the entire rendering architecture is being rebuilt.


          Make sure Magic Bullet is up to date. As good as it is I have not updated my Magic Bullet for quite a while because have a different workflow for color grading.


          The problem I see is with the Render Settings. Quicktime has completely dropped their support for H.264 in a Quicktime container. It never worked well and when it did it was slow to render and unreliable as a delivery format. I would never use that format. If you can use the Adobe Media Encoder to render your h.264 as an MP4 using one of the default presets then that's the way to go. If you render a comp directly in the AME it will take longer than rendering through AE's output module because AE will be running in the background. If you used Ray-tracing and have an NVIDIA / CUDA compatible card then the AME will not use your GPU for rendering and it will take forever and may not work at all.


          I'm assuming this is your final render pass because you are choosing an MPEG format that is really not suitable for further editing and re-compressing. My recommendation would be to first purge your disk and image cache in AE and then render to a suitable production master format from the Render Cue and then encode your H.264 in the AME. Many times this will be faster than rendering a comp directly in the AME. By far the shortest render times in the AME come from a good quality lossless production master. Most of the time I just send renders to the AME directly from AE and then I keep working on other shots because I can't afford to wait for renders. This is the most efficient for me, but if the project is under a tight delivery deadline I'll usually render a production master from AE and then compress it in AME for delivery.


          If you still get the error there could be one other thing going on that may be fixed by changing the cache settings in the Secret panel of your Preferences. You access that panel by holding down the shift key when you open Preferences>General. Disable Layer Cache and purge every few frames.

          Screen Shot 2016-05-09 at 8.15.13 AM.png

          1 person found this helpful
          • 2. Re: Renders failing (RAM issue) on Windows 10
            contr8l Level 1

            Yes, AE and plugins are all up to date. And correct this was the final pass, it's going online and from what I've read most places recommend H264. I wasn't aware of it's lack of support and instability in Quicktime, thanks for the information. I've tried a couple more test renders on Windows 10 with different codecs and am getting good results without failures so it would appear to be a H264/Quicktime issue as you suggested. I will render out a lossless final pass and then encode/compress for delivery in AME or third party.


            I'm relatively new to motion graphics and don't come from a video background so I'm still learning about codecs. Many thanks for your comprehensive response, and I appreciate the insight into your workflow.