6 Replies Latest reply on May 14, 2016 11:33 AM by JimHess

    Moved Lightroom 5 Catalog Previews.lrdata file to External Hard Drive now Images Missing! HELP!!!

    nathandzac777 Level 1

      Hi All,

       

      Please help.  To try and free up space on my MBP with SSD of 128GB I moved the file 'Lightroom' from my 'Pictures' folder to my EHD.  When I opened up LR it couldn't find any images so I moved the file back to my MBP and back in to the 'Pictures' folder.  Only problem is now there are a load of images missing from the last year or so.  I have all my CR2 files on my EHD so luckily I still have the physical copies of the originals but all my edits have gone.  I have spent dozens and dozens of hours editing family shots and other photographs and I am very nervous that I may have just lost them all???

       

      Please please help.......

       

      Thanks...

        • 1. Re: Moved Lightroom 5 Catalog Previews.lrdata file to External Hard Drive now Images Missing! HELP!!!
          JimHess Adobe Community Professional & MVP

          I cannot answer the question about the missing images. However, after you move the Lightroom folder to the EHD you should open that folder and double-click on the catalog file in its new location. After that, if you have your Lightroom preferences set to open the most recent catalog, Lightroom will use the catalog that is located on the EHD.

          • 2. Re: Moved Lightroom 5 Catalog Previews.lrdata file to External Hard Drive now Images Missing! HELP!!!
            nathandzac777 Level 1

            Thanks for the reply Jim.  I had a file for instance labeled 'Family 2016' that LR just does not show up now.  It is still on my EHD with all the RAW files.  I don't know why LR since moving the file does not reference it any longer.  Could it be because on shutdowns in the past when LR has offered to 'Backup' I have declined it??

             

            Many thanks again....

            • 3. Re: Moved Lightroom 5 Catalog Previews.lrdata file to External Hard Drive now Images Missing! HELP!!!
              JimHess Adobe Community Professional & MVP

              That would be difficult to determine. When Lightroom backs up the catalog, it creates a copy as the catalog exists at that moment. If you are certain that you moved the right catalog to the external hard drive, and the "Family 2016" folder is missing, that would seem to indicate that you may have moved a different catalog. If that folder is still in its same location, and you moved the right catalog, it seems to me that everything should still be in place. Are you saying that "Family 2016" doesn't even display in the folder tree in the library module? Do you have any other catalogs?

              • 4. Re: Moved Lightroom 5 Catalog Previews.lrdata file to External Hard Drive now Images Missing! HELP!!!
                nathandzac777 Level 1

                The 'Family 2016' doesn't show up in the tree in the library module.  My last back up shows as July 2015.  Is it the case that anything after that date has lost its reference to LR? 

                 

                I guess I will just have to Import all the images again from my EHD for LR to reference but it is all the work lost to the edits I have done that really concerns me.  I'm pretty sure I only have one catalog.  Up until the point where I made the fatal move of moving Lightroom file from 'Pictures' containing 'Backups', 'Lightroom 5 Catalog Previews.lrdata' and 'Lightroom 5 Catalog.lrcat' every time I opened LR everything was there including all my recent edits.  Baffled as to where things have gone and why LR no longer seems to reference them from my EHD??

                 

                I haven't deleted anything I just moved the file to my EHD and then back to where it was in the first place!!

                 

                Cheers....

                • 5. Re: Moved Lightroom 5 Catalog Previews.lrdata file to External Hard Drive now Images Missing! HELP!!!
                  dj_paige Level 9

                  nathandzac777 wrote:


                  I haven't deleted anything I just moved the file to my EHD and then back to where it was in the first place!!

                   

                   

                  As I'm reading along, I am not sure exact WHAT file you moved to the EHD and then moved back. You state in the title that you moved the Previews.LRDATA, but that is a folder, not a file, and in any case would not cause any of these symptoms. Could you clarify exactly what was moved?

                   

                  Before you import images again (they will not have any edits or user-supplied metadata), which should be the absolute last resort, you might want to check to see if you have accidentally opened the wrong catalog. Go to File->Open Recent and select each catalog to see if the photos/folders you want appear in that catalog.

                  • 6. Re: Moved Lightroom 5 Catalog Previews.lrdata file to External Hard Drive now Images Missing! HELP!!!
                    JimHess Adobe Community Professional & MVP

                    If your last backup is dated July 2015, that means the Lightroom has not created another backup of your catalog for about 10 months. That's not a good idea. I recommend that you configure Lightroom to create a backup at least weekly, and then you should keep several of those backups as a safety precaution. I don't know if you realize this, but backing up the catalog does not create a backup of your images. You are left to your own discretion to determine how your images will be backed up.

                     

                    If, as you say, you moved the entire Lightroom folder from your Pictures folder to the EHD, then opened the folder and double-clicked on the catalog file, everything seemingly should have functioned as it did previously. If possible, could you outline the steps you took to move everything to your external hard drive?

                     

                    One other question. If you open your Lightroom folder how many files (not folders) have the extension .lrcat?