6 Replies Latest reply on Aug 9, 2016 6:18 AM by Davi Lima

    I can't install snap.svg to animate cc

    Yakira

      I want to export svg animation from adobe animate

      I installed the plug in snap.svg and the extension manager cc and I have the adobe desktop app but it's not working.

      what can I do to make it work?

        • 1. Re: I can't install snap.svg to animate cc
          Davi Lima Level 1

          Did anyone succeeded? I'm on Win10+AnimateCC2015/2 pt-br. And you?

          • 2. Re: I can't install snap.svg to animate cc
            Mohanaraj Adobe Employee

            Hi,

            There is an issue with Extension Installation in general if your OS language is different than your application language. Extension Manager team is working on it. Mean while you can just copy the contents from the below folder

            C:\Users\(your user name)\AppData\Local\Adobe\Animate CC 2015.2\(OS locale code)\Configuration\Commands\

            to the following folder

            C:\Users\(your user name)\AppData\Local\Adobe\Animate CC 2015.2\(app locale code)\Configuration\Commands\

             

            If the above solution doesn't work, can you please let us know if you see any error when you install the plugin through WinUtility or through ExManCmd_win?

             

            Thanks!

            Mohan

            • 3. Re: I can't install snap.svg to animate cc
              Davi Lima Level 1

              Both OS and app are in the same language so I only have one single folder (pt_BR) inside C:\Users\Davi\AppData\Local\Adobe\Animate CC 2015.2. Then inside of C:\Users\Davi\AppData\Local\Adobe\Animate CC 2015.2\pt_BR\Configuration\Commands I have 6 JSFL files (Convert To Other Document Formats.jsfl, Copy Font Name for ActionScript.jsfl etc) and a names.xml listing all of them.

               

              How can I get the JSFL files for SnapSVG? I tried unpacking the ZXP file (the one from Github) but didn't find that type of extension.

               

              Finally there are no errors when I install through Extension Manager CC, WinUtility, ExManCmd or Creative Cloud but no files are copied in those folders and nothing shows up in Animate splash screen. And neither if from there I go to Models > General > Type.

               

              Would you have any other hints so we can debug this? I can be on IRC or other kind of chat to make trouble shooting easier.

              • 4. Re: I can't install snap.svg to animate cc
                PrashantGupta Level 2

                Hi,

                SnapSVG is a CEP based extension. CEP extensions are installed at following location :

                Win: C:\Program Files (x86)\Common Files\Adobe\CEP\extensions

                If you already have the zxp file of extension, you can use the WinUtility. Please make sure that you are using the updated WinUtility for Animate 2015.2 (Download here). After successful installation you will get following state in WinUtility: snap.PNG  

                 

                Launch Animate 2015.2 and you will get new doc type as SnapSVGAnimator(Custom). Can you please share the screenshot of your WinUtility state after installation of extension to further investigate this issue?

                Adobe Extension Manager CC has been phased out as a stand-alone product due to its integration with the Creative Cloud application. For more details about extension installation : Install extensions in Adobe Animate

                 

                Thanks,

                Prashant

                • 5. Re: I can't install snap.svg to animate cc
                  Davi Lima Level 1

                  Here it is.

                   

                  Captura de tela 2016-08-09 07.17.21.png

                   

                  I can install Teamviewer or similar so you can inspect it better if you'd like. Here's my C:\Program Files (x86)\Common Files\Adobe\CEP\extensions:

                  • 6. Re: I can't install snap.svg to animate cc
                    Davi Lima Level 1

                    I got it! My Animate CC sync account was misconfigured. After I fixed it, the new Type begun to appear.

                    1 person found this helpful