5 Replies Latest reply on May 29, 2006 10:22 AM by Newsgroup_User

    Buttons not working

    ian_wize
      Using an older version of Flash (FlashMX) for a flash project for my flash class. I went through this fly out menu tutorial:

      Fly out menu Tutorial

      The only thing is I can't get my buttons to work at all once I put the actionscript on it. Anyone know what the problem might be?
        • 1. Re: Buttons not working
          gaurav_ch Level 1
          hi,

          could you post the link to your fla? it will help in analysing the your code.

          gaurav
          • 2. Re: Buttons not working
            ian_wize Level 1
            SCprototype.fla

            The buttons are movie clips. The only actionscript I used is in the "home" button in which I attempted to replay the Lucid Dream Media intro (just to test if the button worked).
            • 3. Re: Buttons not working
              Level 7
              "ian_wize" <webforumsuser@macromedia.com> wrote in message news:e5dv89$pov$1@forums.macromedia.com...
              > <a target=_blank class=ftalternatingbarlinklarge
              > href=" http://www.geocities.com/luciddreamphotography/SCprototype.fla">SCprototyp
              > e.fla</a>
              >
              > The buttons are movie clips. The only actionscript I used is in the "home"
              > button in which I attempted to replay the Lucid Dream Media intro (just to test
              > if the button worked).

              Scene name navigation is really unreliable. Most Flash programmers use frame labels instead. To use frame label nav..

              Open the LDM Intro scene and click on frame 1. Give it a frame label like "intro" by typing the label in the properties menu.
              (no caps)

              Open Suicide Casanova scene and dbl click on the home button movieclip. Move the timeline slider to frame 15. That's where the
              button is when the mouse is hovering over it.
              (It has different code on it in several places of the timeline)
              Click once on the home button. You will see this code attached to the button..
              on (release) {
              gotoAndPlay("HopeWorks");
              }


              Change it to this..

              on (release) {
              _root.gotoAndPlay("intro");
              }

              Make sure you are on frame 15 of the movieclip with the name of "home(button)ANIM" when you add the button code.
              tralfaz


              • 4. Re: Buttons not working
                ian_wize Level 1
                Wow thanks so much! I didn't know the problem was so minor. Four hours of work lost b/c of it haha. Thanks again friend!
                • 5. Re: Buttons not working
                  Level 7
                  "ian_wize" <webforumsuser@macromedia.com> wrote in message news:e5f5hq$e85$1@forums.macromedia.com...
                  > Wow thanks so much! I didn't know the problem was so minor. Four hours of work lost b/c of it haha. Thanks again friend!

                  Don't worry, you're not the first person to lose time over the scene name navigation fiasco. It's been a problem for a long time.
                  tralfaz