1 Reply Latest reply on May 24, 2016 12:43 PM by dha2

    CF 2016, Apache 2.4 on Win10 CFImage error

    dha2 Level 1

      I have a Windows 10 system with Apache 2.4 where I do ColdFusion development for a client who is considering an upgrade to ColdFusion 2016.   I installed a trial CF (planning to use it as a development after 30 days) and it works so far except for scripts with CFIMAGE with WritetoBrowser.

      The browser debug tools in Firefox show an error: "NetworkError: 403 Forbidden - http://{vhostname}/CFFileServlet/_cf_image/_cfimg2.....jpg".

      The Apache {vhostname}-error.log shows the following: "AH01630: client denied by server configuration: C:/CFusion2016 ...."

       

      I earlier tried CF2016 on an older Windows 10 system with Apache2.2 and the applications using CFImage all seem to work fine there.   I understand there were numerous security changes from Apache2.2 to 2.4.   I suspect the mapping of CCFileServlet is behind the problem but nothing I have tried seems to make it work.  I am looking for ideas before I ditch the Apache2.4 - I would rather not go backwards with versions.