2 Replies Latest reply on May 22, 2016 10:21 AM by Steve Grisetti

    Premiere elements for PC  BUSINESS ON THE LINE

    pse1520

      Premiere elements for PC    I stayed up all might trying to get one clients job completed and had no issues with this "photo" portion   but when i click on the purple 'premiere' elements app it always pulls up a screen with the three options.  On the far left is "photo" and in the middle is "organizer"  both of which open as usual.  But suddenly my "video" option won't do anything. It shows the little circle as though it were loading.  But after 5-15 seconds, the loading symbol disappers and NOTHING happens it just keeps the original opening page on the screen and doesn't lock up or anything  I've tried basic things like turning my computer off and back on. Same result.  There's no error or "failed" message which makes it worse.  I DESPERATLEY NEED HELP!!

       

      [Asking in the correct forum helps... Moved from Connections forum to specific Program forum... Mod]