2 Replies Latest reply on May 28, 2006 4:53 PM by Terrence Martineau

    XML problems...

    Terrence Martineau
      i import the text from a file into a cast member and then parse the string with the xml parser... i added alerts all along the way so i could see where things go bad in the projector and i think the xml parser object is not being created when i create a projector. everything works fine during author mode but i get a script error with the projector.
      director MX 9.0...not 2004
        • 1. Re: XML problems...
          Level 7
          > everything works fine during author mode but i get a
          > script error with the projector.

          And what does the script error dialog say - make sure you enable
          'Display full script error text' in the Publish Settings -> Projector tab.
          Is it as simple as neglecting to include the XML Parser xtra either in a
          Xtras folder alongside the projector or bundled into it? Check Modify ->
          Movie -> Xtras and make sure you added it to the list - it's a scripting
          xtra, not an asset xtra, so isn't auto-added.
          • 2. XML problems...
            Terrence Martineau Level 1
            Sean,

            I can't say thank you enough... you saved me.. BIG TIME!! did all this work and then couldn't make a projector.. it was the xml parser that wasn't being included. maybe i should upgrade to mx 2004 since it seems to have some nice upgrades. in dir mx "projector" is not included in publish settings just web publish settings you need to go to Modify>Movie>Xtras to set the xtras that get included.. the "Display full script error text" would be nice too... but you sent me on the right track for the fix... thanks again.

            T.