13 Replies Latest reply on Jun 21, 2016 9:02 PM by little fat girl

    Canvas publishing produces Uncaught TypeErrors

    little fat girl Level 1

      So, I'm trying to export a looping logo animation. It worked the first time I published and now simply won't work. I get Uncaught TypeErrors and the screen is white when I publish.

       

      Even more frustrating is the fact that I get different errors at different times. The most frequent error is this:

       

      Uncaught TypeError: lib.machinelogocathead is not a constructor

       

      It's referring to a MovieClip that I'm animating. But sometimes I get other errors that keep it from working.

       

      I think my problem is similar to this one:

       

      Publishing to JS/HTML errors

       

      If I simplify the animation, removing stuff, I can get it to work. But there is no one part that causes the error. In other words, there is no one element I can isolate as the problem.

       

      Mostly it's frustrating because it worked fine the first time and now it won't.

       

      Is there a way around this?