0 Replies Latest reply on Jun 4, 2016 2:40 PM by loyd.michael

    Default Document not being honored after upgrade to CF11


      Windows 2008 R2

      IIS 7.5

      ColdFusion 11


      We just upgraded our production environment from CF10 to CF11. We ran onto some snags with the dev environment on the upgrade, but not this particular issue.

      The issue seems to be that the default/welcome document is not being honored.



      If I go to http://server/dir/default.cfm everything is cool, but if I go to http://server/dir/ I get a 404 error.


      HTTP Error 404.2 - Not Found

      The page you are requesting cannot be served because of the ISAPI and CGI Restriction list settings on the Web server.


      Detailed Error Information


      Error Code0x800704ec



      Requested URLhttp://server:80/default.cfm
      Physical PathX:\dir\root\default.cfm
      Logon MethodAnonymous
      Logon UserAnonymous



      Now I have checked/deleted/added the Handler Mappings, ISAPI Filters, and ISAPI and CGI Restrictions until I am half-mad. I have deleted the connector with wsconfig loads of times, and the only thing I see that stands out is in the isapi_redirect.log:

      [debug] handle_notify_event::jk_isapi_plugin.c (2505): [/] is not a servlet url


      I have checked permissions, checked everything I can find, and this time the forum below is not the answer. The IIS server serves up all the cfm files, etc. fine, it is just using the dir only that we have a problem (again).


      Oh the irony, the closest issue I see in the forums, is from my own when we upgraded to 10 > Default Document not being honored after upgrade to CF10