6 Replies Latest reply on Jun 9, 2016 12:29 PM by vangroover

    iOS build crash - "build server error"

    marcs13734498

      hello everyone,

       

      Since 2 days ago I'm getting this message when I try to compile iOS version:

       

      Oh geez. Your build failed. Sorry, but a problem occurred on the build server - We have been notified

      An intern has been dispatched to sit next to our development team and make well-timed passive aggressive jabs at them until they resolve the issue.

      You will be politely notified when some action has taken place.

      Please note: if you delete your app, we won't be able to debug it (to help you and anyone else who might encounter this issue). If you keep the app around, we'll email you and let you know what was wrong.

      But I've not received anything...

       

      I get this error since i use this parameters in the config.xml:

       

      <preference name="phonegap-version" value="cli-6.1.0" />

       

      I need this line because if i remove it, then it compiles with iOS 3.9.1, and I get this (pasted from log),

       

      Fetching plugin "phonegap-plugin-push" via npm

      Installing "phonegap-plugin-push" at "1.7.0" for ios

      Plugin doesn't support this project's cordova-ios version. cordova-ios: 3.9.1, failed version requirement: >=4.1.0

      Skipping 'phonegap-plugin-push' for ios

       

      So my app is being compiled, but phonegap-plugin-push won't install.

       

      Any idea of what can I do? Is there any other way to specify iOS compiling version? Should I wait for an email from the phonegap team?

       

      Thanks!