2 Replies Latest reply on Jun 10, 2016 12:37 PM by yourtoastisdone

    Kobe e-reader

    jf31357377

      I downloaded a book from my local library to Adobe Digital Editions 4.5.  Then transferred it to my Kobo Aura H20 e-reader.  When I attempted to open the book I received the following pop up message:

      Oops!  This document couldn't be opened.

      This document is protected by Adobe Digital Management (DRM) and is not currently authorized for use with your Adobe ID.  Please sign-in with the authorized Adobe ID and try

      again.

      I verified that my account is authorized.

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

      adobe Digital Management

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

      i

        • 1. Re: Kobe e-reader
          ronf29896630 Level 1

          I had the same issue. Apparently there is a glitch with Adobe 4.5. The solution I implemented was to uninstall version 4.5 and reinstall version 3 and that seemed to resolve the problem.

          1 person found this helpful
          • 2. Re: Kobe e-reader
            yourtoastisdone

            Yes, I had this same problem (with exactly the same device) and spent hours trying to fix it. Managed to temporarily fix it once by deleting the authorization file, uninstalling adobe and reinstalling it. Then the next time it happened I had to create a new adobe ID and that fixed it for one book and then it broke again. Installing Adobe Digital Editions 3.0 seems to have fixed it so far. Link to download that is here: Adobe Digital Editions downloads

             

            I really hope Adobe fixes version 4.5 soon. In case it is relevant, I'm on a Mac on El Capitan OSX 10.11.5. Not sure what OS the OP might be using.