1 Reply Latest reply on Jun 10, 2016 6:15 AM by Steve Grisetti

    Am I trapped with Mountain Lion OSX 10.8.5?

    babytrash

      I have Photoshop & Premiere elements 9 and have purchased the upgrade for both to v14. I have AVID ProTools 11. I have Mountain Lion 10.8.5.

      I run a home studio for music and film production.

      According to the online research I've already done, these applications can only co-exist and operate on Yosemite OSX 10.10.x.

      Yosemite is not available through Apple's Online store.

      While I could upgrade to El Capitan, Avid advise they have no intention of modifying PT11 to make it compatible; they would prefer you change to their annual subscription product equivalent (ProTools v12).

      I'm very happy with ProTools the way it is.

       

      If I install the two Adobe v14 products on OSX 10.8.5, will they work or am I going to initiate unforseen problems?