13 Replies Latest reply on Jan 12, 2018 8:41 AM by maria__

    why is "movie not loaded" all browsers 2016

    carbonfixa

      I get the "movie not loaded" and blank screen for any flash movie in all browsers.

       

      I've done clean installs of  Mountain Lion, Yosemite, Mavericks and now El Capitan

       

      I've uninstalled flash reinstalled the latest flash logged into a TV on demand site as another user (to check that it's not my personal adobe account issue)

       

      Still No flash.

       

      Any more suggestions

        • 1. Re: why is "movie not loaded" all browsers 2016
          jeromiec83223024 Adobe Employee

          It sounds like you're getting this one just one website, is that the case?

           

          Do you see the Flash content here?

          http://www.homestarrunner.com/

          • 2. Re: why is "movie not loaded" all browsers 2016
            carbonfixa Level 1

            Looks like you're onto it, yes I can see the Flash content on that link:

             

            http://www.homestarrunner.com/

             

            But not this one, which which is our main Television channel:

             

            Watch George Clarke's Amazing Spaces - Sunday 5 Jun - TVNZ OnDemand

             

            Any suggestions?

            • 3. Re: why is "movie not loaded" all browsers 2016
              jeromiec83223024 Adobe Employee

              So the player is installed and working fine.  The problem is with the content.

               

              You can try clearing your browser's cache or using incognito/private browing mode.  It's possible that maybe you've just cached a corrupted copy of the content locally.  If that's the case, the movie should play normally in either scenario.

               

              If that's not the case, the content they're serving fails our validation or security checks.  That seems odd, but we're continually hardening Flash Player against increasingly sophisticated attackers, and it's possible that a problem with the content may have been ignored.  Unfortunately, if that's the case, the content provider will need to resolve the problem, most likely by recompiling their content with a current version of the compiler.

               

              Thanks!

              • 4. Re: why is "movie not loaded" all browsers 2016
                carbonfixa Level 1

                This site is the major Television Channel in our country with thousands of on demand shows for registered customers, of which I'm one

                 

                TV Shows A-Z - TVNZ OnDemand

                 

                I've cleared all browser caches and history, run as private or incognito and still I get "movie not loaded"

                 

                when we use our iPad to view this same site, it runs well but with the same user on our Macbook pro, no go.

                 

                I've uninstalled Flash, reinstalled clean but still "movie not loaded"

                 

                It seems to be:

                1/ Flash on this machine

                2/ This site only on this machine

                • 5. Re: why is "movie not loaded" all browsers 2016
                  jeromiec83223024 Adobe Employee

                  We can try blowing away all of Flash Player's data files and DRM content licenses.  This is one of the things that TVNZ is recommending, and fits with my intuition. 

                   

                  If you go to Settings > Control Panel > Flash Player > Protected Content > Deauthorize This Computer and Browsing Data and Settings > Delete All, does that help for Firefox or Safari?  Chrome has a different procedure: Chrome > Menu (the sandwich icon to the right of the address bar) > Settings > Show Advanced Settings > Privacy Settings > Clear Browsing Data > Content Licenses

                   

                  Flash Player isn't supported on iPad, so it sounds like TVNZ has a dedicated app or site for iPad users.  You might try just disabling Flash Player temporarily to see if they'll fall back to HTML5 video if Flash isn't present.

                   

                  You said all browsers, but is one of them Google Chrome?  Chrome has a significantly different Flash implementation, and all of the settings and data files for Chrome are encapsulated.  It's an interesting data point.

                   

                  If that doesn't work, there aren't really a lot of knobs left to turn from the client perspective.  TVNZ is geographically restricted, and I don't have a New Zealand endpoint with which to play with it.  I *do* know that there are no similar widespread problems with US-based services using the same DRM technology, so it's quite likely that it's either a problem with their service, or there are things that we can help them do on the back-end to diagnose and get any widespread problem with the service resolved.

                   

                  To get that ball rolling, I'd recommend that you talk to TVNZ directly:

                  Frequently Asked Questions - TVNZ OnDemand

                   

                  They'll have a lot more information about any local problems and aggregate data about problems with their service, and are well positioned to escalate the problem through our DRM team if it proves to be widespread.  You're absolutely welcome to refer them to this thread, and they're welcome to reach out to me through private message by clicking my username if they need a direct adobe contact.

                   

                  Hopefully clearing the DRM licenses resolves the issue

                  • 6. Re: why is "movie not loaded" all browsers 2016
                    seoexport01

                    hi i need for head in site [link removed] flash plz help not play and use.are you my system not operate.

                    • 7. Re: why is "movie not loaded" all browsers 2016
                      z_kenny Level 1

                      Hi there,

                       

                      I have a website that we use for testing at work with one of our projects and am having the same issue.

                       

                      I have several SWFs embedded using the object tag on the page and most of them are working fine, but there are a few that aren't showing up and I get the white "movie not loaded" box.

                       

                      I have tried all manner of clearing browsing data, resetting Flash licences etc but I have the same problem on multiple computers on various browsers.

                      here is the URL: [link removed]

                      You can view the page source to see the code I'm using and see that there's no difference between the code being used for the SWFs that are working and those that aren't.

                       

                      Thinking it might be a content issue, I tried generating a new version of "1_4_whatIsCancerStaging.swf" using Flash Player 10 in the publish settings. I know that FP10 has some stricter publish settings such as not allowing TLF text, so I thought this might help, but I'm still getting the same problem.

                       

                      Any help would be appreciate, thank you.

                      • 8. Re: why is "movie not loaded" all browsers 2016
                        z_kenny Level 1

                        Hi There,

                         

                        So I actually just figured it out.

                         

                        First step of course would be to do all the clear cache stuff that seems to help 99% of the people with the problem.

                         

                        In my case, there was a problem with the SWF itself.  There is an error that isn't displayed when the swf fails to load inside the html, but if you open the swf itself with your browser, you will see the error.  The error I got was "SecurityError: Error #2149: Security sandbox violation... at flash.system::FSCommand$/_fscommand()".

                         

                        I tried changing the "Local Playback Security" in the publish settings, but it didn't make any difference.  When I deleted the fscommand("allowscale", "false"); line from the AS in my FLA and published the swf and opened the swf in my browser, I did not get the error. 

                         

                        What still puzzles me is that all of the other swfs that were working and still work, all have the same line of code in them, and use the same publish settings, so I still don't really know what the specific issue is, just a quick work around that worked for me.

                         

                        Hope this helps!

                        • 9. Re: why is "movie not loaded" all browsers 2016
                          jeromiec83223024 Adobe Employee

                          Local playback security is all about playing a local file (e.g. a SWF on your desktop), so that probably wouldn't have helped at all.

                           

                          That error doesn't make a lot of sense to me, and my guess is that either this particular SWF was subtly corrupted on disk, or the compiler used at the time generated a malformed SWF. 

                           

                          We're constantly hardening Flash Player against an ever-increasingly sophisticated community of adversaries, and although we try to maintain backwards compatibility, it's quite possible that there was a subtle error in the bytecode or something that we were no longer forgiving.  My guess is that recompiling the SWF either resolved the on-disk corruption, or a more recent version of the compiler included a fix for whatever was causing the malformed bytecode to be emitted in the first place.

                          • 10. Re: why is "movie not loaded" all browsers 2016
                            jeromiec83223024 Adobe Employee

                            Also, I'd love to get samples of the busted files for analysis.  Feel free to shoot me a PM with links, or open a bug over at http://bugbase.adobe.com/, and attach them.  I'd like to figure out definitely what's going on and see if we can't provide some pain relief for other folks in the same boat.

                            • 11. Re: why is "movie not loaded" all browsers 2016
                              z_kenny Level 1

                              Just following up:

                               

                              jeromiec83223024 took a look at my page and determined that the SWF files that were not displaying and showing up as "movie not loaded" had a Error which has to do with the file permissions.  Somehow 3 of the 18 SWFs on my page had different file server permissions.  I could see the permissions on the faulty files and those of the files that were working and I could see the difference, but I couldn't figure out how to add the permission to the faulty files. I assumed that since the rest of them were working, that the folder itself probably had the right permissions so I guessed that any new files that were added would adopt those correct permissions.  So I re-named the problem files with a new filename, changed the paths in the HTML and uploaded the files to the folder and now everything works.

                              • 12. Re: why is "movie not loaded" all browsers 2016
                                stoem Level 1

                                For future reference there have been changes to the allowScriptAccess parameter and the use of FSCommand.

                                Changes in allowScriptAccess default in Flash Player

                                 

                                This doesn't seem to have helped my issue with 'movie not loaded' but it may be cause for other people's problems.

                                • 13. Re: why is "movie not loaded" all browsers 2016
                                  maria__ Adobe Employee

                                  The tech note you link to was last updated Jan 2016.  This discussion topic was started in June 2016, as such, the changes you reference were already present in June 2016.

                                   

                                  As their have been significant changes in how browser's handle/load Flash since this discussion was started in June 2016 it's most likely that whatever you're experiencing is not related.  I'm going to lock this discussion topic due to it's age.


                                  If you're experiencing issues with Flash Player, please start a new discussion topic and provide the following information:

                                   

                                  • Operating system version
                                  • Web browser and version
                                  • Flash Player version
                                  • Explain your problem in step-by-step detail if possible
                                  • A direct link to a web page that demonstrates the problem
                                  • If you get error messages, please provide a screenshot