6 Replies Latest reply on May 2, 2006 2:28 PM by Newsgroup_User

    Robo Corrupting Java Script

    Mary2Names
      I am wondering if anyone has seen anything like this.

      Someone in our group wrote a java script we use to open and close popups with screen illustrations in them. This script has worked fined in numerous projects. The usual way to insert the script in the topic is to go into True Code view, copy the script, and paste it into the topic.

      Suddenly when I copy and paste the script from one topic to another, Robo replaces an open {, a couple of spaces between different lines in the code, and a close } with a thick vertical bar. (The bar becomes an underline when copied into WordPad.) I then get runtime errors.

      I tried re-creating the topic from scratch in a test file, testing the open/close after each popup was added. It worked just fine. I deleted the old corrupted file from the project and renamed the test file with a similar name, then inserted it into the correct place in the Table of Contents. I removed all hyperlinks to the old file and replaced them with links to the new file. I tested the new file and it was fine.... until I went into True Code to look at a spacing problem between words in a sentence. As soon as I went back to WSYIWYG view the java script was corrupted.

      I de-installed RoboHelp, then re-installed Microsoft Office with the error correction feature enabled. Then I re-installed Robo. It didn't help.

      Could it be related to the Table of Contents? The files don't seem to corrupt unless I open them from the TOC view.

      As you can tell I'm grasping at any idea that might help.