2 Replies Latest reply on Oct 3, 2006 2:32 AM by hrmalik

    RoboHelp crashes when working with Templates

    hrmalik
      Hi,

      I have RoboOffice X5. While working with templates in RoboHelp HTML the application crashes giving a memory reference error.

      I designed an HTML page in Macromedia Dreamweaver. The page layout is designed using the DIV tags. The page also has a CSS file containing all the rules for the HTML elements in the Web page. I import this Web page in RoboHelp HTML as a new topic and then add it to the template gallery. It works fine this far. When I try to create a new topic using the template RoboHelp crashes. This even happens when I edit or delete the template.

        • 1. RoboHelp crashes when working with Templates
          CraigCC Level 2
          Hi Hrmalik,

          Three things come to mind. Have you set up Dreamweaver as your default editor (Under Tools | Options| HTML Editor. Does this problem occur only when you import the topic to the template gallery? What happens when you import the topic as an HTML File (using the File | Import | HTML File option)? I'm wondering why you need this file as a template - Robohelp templates do not work in the same way as Dreamweaver templates, they are normally just used to to add basic header and footer info - no where near as sophicated as Dreamweaver. Lastly, are you working with the project locally (good), rather than on the network (bad).

          Kind Regards
          Craig
          • 2. Re: RoboHelp crashes when working with Templates
            hrmalik Level 1
            Craig,

            I'm using the RoboHelp WYSIWYG editor as default and I'm working with the project locally. The reason for using Dreamweaver is:

            1) its designer - better than RoboHelp's
            2) good support for CSS

            I tried two methods for including the template in my project.

            1) By importing it as a topic and then adding it to the gallery through the Right Click | Add to Template command.
            2) By importing it directly as a template in the Templates area after renaming the .html file to .htt

            The problem occurs when I create a new topic based on the template.

            " I'm wondering why you need this file as a template - Robohelp templates do not work in the same way as Dreamweaver templates, they are normally just used to to add basic header and footer info - no where near as sophicated as Dreamweaver. "

            What I wanted to do was design a layout and a set of text formattings that I can use for some of my topics (in a similar fashion as we do in Dreamweaver). But, as you have said, if RoboHelp templates are only for adding basic headers and footers then I guess that is the reason behind the crashing of the program.