2 Replies Latest reply on Sep 23, 2016 6:18 AM by helenfake

    Youtube in Phonegap

    muhammada2545796

      Hi,

       

      i embeded a youtube video in my app when i tested it in my android phone using phonegap developer app it works fine!

      but when i download apk file from build phonegap the youtube videos are not showing like i've not putted them.

       

      please help is there any special code to display youtube videos in phonegap?

       

      the code i used:

      <iframe allowfullscreen="" frameborder="0" height="100%" src="https://www.youtube.com/embed/uxTChOEdHoA" width="100%"></iframe>

        • 1. Re: Youtube in Phonegap
          kerrishotts Adobe Community Professional

          Please share your config.xml file and the HEAD portion of your index.html file. Also, do you get any errors in the JavaScript console (chrome://inspect) or the device console (adb logcat)?

          • 2. Re: Youtube in Phonegap
            helenfake

            Hi Kerri,

             

            I am having a similar issue.  The YouTube vids work in my mobile ready version and not when the file is converted to an .apk format.

             

            To give you a little more context, I packaged the app using Adobe Captivate.  I embedded web objects that pull the https:// files from youtube (all youtube vids now have the https:// start).  I ran a debugger on the app and it says it can't find the youtube video/that there is a youtube video error.  Instead of pulling the youtube file with the https:// beginning it is converting it into file:// at the beginning.  I had a developer look at it and he says that it may have to do with permissions.

             

            I'm not a coder and I have looked at the documentation for integrating YouTube into an app, but I'm not clear where to put that code since I've published using Adobe Captivate.  Also, we tried to set some permissions in the XML file that I had to create and those aren't seeming to work either.  Do you have any resources/support contact that I can reach out to in order to get this problem resolved?  If not, is there a way to package my already mobile ready version of the site into a hybrid app?  Thanks.