4 Replies Latest reply on Jun 19, 2016 12:07 PM by jane-e

    How can I prevent inDesign from listing Asian fonts I'll never use.

    Ryadia™ Level 1

      Hi all,

      I'm pretty fed up with the overpowering list of Asian fonts I'll never use showing up in inDesign whenever I go to change a typeface or font. Is there any way to prevent inDesign CC from doing this? It really is quite annoying. I run with the barest minimum of fonts to get maximum performance from Windows. Even removing the fonts from Windows font folder has no effect.

       

      Thanks in advance for any help.

        • 1. Re: How can I prevent inDesign from listing Asian fonts I'll never use.
          Salah Fadlabi Level 5

          Even removing the fonts from Windows font folder has no effect.

          Check indesign fonts folder it maybe there.

          • 2. Re: How can I prevent inDesign from listing Asian fonts I'll never use.
            Joel Cherney Adobe Community Professional & MVP

            Contemporary versions of Windows require all of those fonts to remain installed. If I recall correctly, Windows will automatically reinstall these fonts if removed. Windows 7 and subsequent versions have the power to hide fonts, when you are in the Fonts folder, and I know that these hidden fonts don't show up in Office apps, although I don't know about how well the OS hides fonts from InDesign. 

            • 3. Re: How can I prevent inDesign from listing Asian fonts I'll never use.
              winterm Level 4

              I hate to say this, but:

              with all my respect to MVP, most of your statements are not true.

               

              Contemporary versions of Windows require all of those fonts to remain installed. If I recall correctly, Windows will automatically reinstall these fonts if removed.

              Yes, there is a good bunch of fonts with the TrustedInstaller account attached (some 'Asian', too). However, this doesn't mean they are really 'system required'. Most of them can be safely removed. And no, Windows won't automatically reinstall these fonts.

               

              Windows 7 and subsequent versions have the power to hide fonts, when you are in the Fonts folder, and I know that these hidden fonts don't show up in Office apps...

              Unfortunately, they still do show up in Office apps, the same about Adobe, Corel, etc. products - you name it. Hiding fonts works just for 'native' Windows OS apps, like Notepad, Wordpad, Paint. It makes this 'feature' pretty useless, imo.

               

              So, the bottom line:

              1. It's possible to clean up your Fonts folder significantly.

              2. It's not a simple task, you must know what you're doing. Always be on the safe side, do backups.

              3. There are fonts you won't want to touch, ever. Do a 'Don't Touch' list! Like Arial, Segoe, Tahoma, Verdana, ZWAdobeF, some others. Good news - Asian fonts not included

              4. The safest way is to disable unwanted fonts in registry first, without physical removing font files, and test the system for a while.

              5. Don't expect detailed instructions here, since this is NOT InDesign question. It's OS related. Use Google, visit Windows forums.

               

              Good luck.

              • 4. Re: How can I prevent inDesign from listing Asian fonts I'll never use.
                jane-e Adobe Community Professional

                Ryadia™ wrote:

                 

                It really is quite annoying. I run with the barest minimum of fonts to get maximum performance from Windows. Even removing the fonts from Windows font folder has no effect.

                 

                Ryadia,

                 

                Since you use the "barest minimum of fonts", another idea is to click the stars of the ones you use to "favorite" them. Then filter to your favorites list by clicking the Star next to the word Filter. In this screen shot I have filtered to three fonts. I can expand the arrows to show Regular, Italic, Bold, etc.

                 

                To remove the filter, click the Star again.

                 

                This is sticky, and it's easy. I think you'll like it.