3 Replies Latest reply on Jul 6, 2016 1:27 AM by garrymargolis

    Lightroom CC (2015) Hangs

    garrymargolis

      I am running Lightroom CC (2015) - the latest update - on OS X 10.11.5 with 16 GB RAM and plenty of free disk space.

       

      The trouble started when I was reviewing newly imported RAW images (on an external drive) in the Develop module. Lightroom froze and would not advance to the next image. I force quit and found that while the Lightroom application quit, another application titled Adobe Lightroom was running, and I could not force quit it -- it kept running. I attempted to restart, and the Adobe Lightroom application prevented the restart. I checked Activity Monitor and could not find this application running.

       

      I forced a shutdown, rebooted, and launched Lightroom. It gave me the dialog that it couldn't find the previous catalog, but that catalog was the one I worked on previous to the one that precipitated the hang, and it couldn't find it because I'd changed the name of its elements. I tried to open the catalog I'd been working on, and Lightroom froze after about a second. I force quit it and found the Adobe Lightroom application still running, as above, and it couldn't be quit.

       

      I forced a shutdown and restarted in Safe Mode, and the behavior was the same.

       

      I trashed all of the com.adobe.lightroom.plist files for all versions of Lightroom in the ~/Library/Preferences/ folder. When I launched Lightroom, the behavior was the same as above. I don't know where Lightroom stores the list of previous catalogs, but it isn't in the .plist.

       

      I again forced a shutdown, rebooted, and uninstalled Lightroom using the Uninstall application. When it completed, there was a 57 KB file left in the folder called Adobe Lightroom which could not be trashed because it was running, and I couldn't force quit it.

       

      I forced a shutdown, restarted, and was able to delete the Adobe Lightroom 57 KB file. I relaunched Lightroom, and the behavior was the same.

       

      I don't know what else to do. Any additional troubleshooting recommendations would be very much appreciated.

       

      Thanks in advance!

       

      Garry

        • 1. Re: Lightroom CC (2015) Hangs
          dj_paige Level 9

          In the same folder as your catalog file is a file whose name ends with .LOCK

           

          Delete this .LOCK file

           

          Do not delete anything else.

          • 2. Re: Lightroom CC (2015) Hangs
            garrymargolis Level 1

            Thanks for the very prompt response! I'd forgotten about the .lock file.

             

            I deleted the .lock file, then attempted to relaunch Lightroom by double-clicking on the desired catalog file. Lightroom launched with the same "catalog not found" dialog. I selected the desired catalog, clicked the "check integrity" box, and tried to open it. After about two seconds, Lightroom hung again. When I force quit it, the Adobe Lightroom application was not running.

             

            However, the external hard drive on which the catalog and images reside could not be ejected (application in use).

             

            Any other ideas? Thanks!

            • 3. Re: Lightroom CC (2015) Hangs
              garrymargolis Level 1

              Problem solved. The catalog was corrupt.

               

              Moral of the story: always keep a backup (or two) of the original RAW images.