14 Replies Latest reply on Oct 26, 2016 8:27 PM by Willi Adelberger

    Non-breaking space as GREP not recognised?

    sPretzel Level 1

      Hello,

       

      I am trying to insert a non-breaking space within a paragraph style's numbering. I do this via GREP text characters. The GREP text for a non-breaking space is "^S". In the Paragraph Style's Bullets and Numbering menu, under Number Style > Number, I type for example: "Text^SHello". I am expecting to see "Text Hello". But I see "Text^SHello" come out. It looks as though "^S" is not recognised. Is this a bug or am I doing something wrong?

       

      This is for CS4.

       

      Thanks.

        • 1. Re: Non-breaking space as GREP not recognised?
          vladan saveljic Level 4

          in the paragraph style bulleted and numbered list you can't insert non breaking space.

          Why do you need this?

          • 2. Re: Non-breaking space as GREP not recognised?
            Peter Spier Most Valuable Participant (Moderator)

            There does not appear to be a meta-character for the non-breaking space (GREP is not an option for this). Have you tried pasting one from the clipboard? How would you know if the space is non-breaking?

            • 3. Re: Non-breaking space as GREP not recognised?
              vladan saveljic Level 4

              I don't know why do you need the non breaking space in yor Paragraph style > "Bullets and numbering" but you can create character style with No Break option ticked and assign that character style in your Paragraph style > "Bullets and numbering" > Character style

              • 4. Re: Non-breaking space as GREP not recognised?
                sPretzel Level 1

                Hi Peter,

                 

                Sorry, I think I used the wrong word. The text meta-character for non-breaking space is ^S (that's what I want to use). The GREP character is ~s.

                 

                premio_oscar: "in the paragraph style bulleted and numbered list you can't insert non breaking space."

                I guess that is my question. Is that a fact? Perhaps you can point me to the Adobe InDesign online guide page where I can read about it.

                • 5. Re: Non-breaking space as GREP not recognised?
                  Peter Spier Most Valuable Participant (Moderator)

                  sPretzel wrote:

                   

                  Hi Peter,

                   

                  Sorry, I think I used the wrong word. The text meta-character for non-breaking space is ^S (that's what I want to use). The GREP character is ~s.

                   

                  premio_oscar: "in the paragraph style bulleted and numbered list you can't insert non breaking space."

                  I guess that is my question. Is that a fact? Perhaps you can point me to the Adobe InDesign online guide page where I can read about it.

                  Empirical testing says there is no meta character for the non-breaking space. I was able to paste a copied NBS into the dialog, but there is no way to test if it functions any differently than an ordinary space.

                   

                  As far as I can tell  the question is moot -- the entire number prefix is non-breaking, like it or not, and it will not break across two lines ever.

                  • 6. Re: Non-breaking space as GREP not recognised?
                    rob day Adobe Community Professional & MVP

                    Is that a fact? Perhaps you can point me to the Adobe InDesign online guide page where I can read about it.

                    You can't select the number and space in a numbered list and when you show invisibles, the tab or whatever white space that is chosen doesn't show. You would have to choose Paragraph> Convert Bullets and Numbering to Text in order to get an editable number and white space character.

                     

                    Screen Shot 2016-06-20 at 9.25.19 AM.png

                    • 7. Re: Non-breaking space as GREP not recognised?
                      sPretzel Level 1

                      Hi Rob,

                       

                      But in your example, you do get the tab for "^t", you don't get "^t" in the text. If I write "^S" in there, I get "^S" in the text! That's the part that I don't understand.

                      • 8. Re: Non-breaking space as GREP not recognised?
                        rob day Adobe Community Professional & MVP

                        If I write "^S" in there, I get "^S" in the text!

                        Right, it's because a non-breaking space isn't an option as a white space choice between the number and text. As Peter pointed out whatever space you use is non-breaking, so you could use a punctuation space and it won't break.

                        • 9. Re: Non-breaking space as GREP not recognised?
                          sPretzel Level 1

                          No, the space does break! A regular punctuation space inserted in the Number field in a pargraph style can break. However, I must add that in my case, I am using this paragraph style in the context of a cross-reference. My numbered paragraph style is for a caption like "Table 2-a". When I insert a cross reference to Table 2-a, the space between "Table" and "2-a" can break. I would like to find a way to avoid that and make the space non-breaking.

                          • 10. Re: Non-breaking space as GREP not recognised?
                            rob day Adobe Community Professional & MVP

                            No, the space does break! A regular punctuation space inserted in the Number field in a pargraph style can break.

                            I'm not see that. I can't set my insertion point anywhere in the numbering text and even force a break. Can you show us a screen capture with invisibles on?

                             

                             

                            Screen Shot 2016-06-20 at 11.41.15 AM.png

                            • 11. Re: Non-breaking space as GREP not recognised?
                              Peter Spier Most Valuable Participant (Moderator)

                              OK, we're not talking about number prefixes any longer, we're talking about cross references. Different animal.

                               

                              I just tried pasting a non-breaking space into the prefix filed in the numbered list dialog, then making a cross-reference formatted to show paragraph number. The non-breaking space I pasted is preserved.

                              • 12. Re: Non-breaking space as GREP not recognised?
                                sPretzel Level 1

                                Indeed, by copying and pasting a non-breaking space into the prefix field (Number), then inserting or updating an existing cross-reference, the space in the cross-reference no longer breaks. I find it odd that you can paste a non-breaking space into the paragraph style prefix field but not use "^S".

                                • 13. Re: Non-breaking space as GREP not recognised?
                                  biancaho

                                  I am having the same issue as sPreztel... I would like to insert a non-breaking space into the cross-reference... I am using 'Figure #' throughout my document and I would like to ensure that there the there is a non-breaking space between 'Figure' and the # so that the two aren't separated onto different lines.

                                   

                                  I had originally automated the numbering of all the figures in 'Bullets and Numbering' and then throughout the document Cross References references the 'bullets' or, in my case, 'Figure #'. There are instances in which 'Figure' and the number are separated as I have said above. I can use 'Find/Change' and use GREP to search for all the breaking spaces that occur after 'Figure' and replace them with '~s' (non-breaking spaces), or just manually paste it in... However this causes an error in my cross-references... but putting '~s' into Bullets and Numbering causes '~s' to actually appearing in my automated numbering of the figures. So, I am getting 'Figure~s1' or whatever number it happens to be...... This also would mean I can't update my cross references without having to do another round of 'Find/Change'. (Just an aside, I have tried both ^s and ~s and neither work in any scenario.)

                                   

                                  Is there really no actual solution for this?

                                  • 14. Re: Non-breaking space as GREP not recognised?
                                    Willi Adelberger Most Valuable Participant

                                    Peter has given the answer which applies to you: Create your own cross reference setting which includes a non-breaking style. If you copy a no breaking style into the dialog of the creating a cross-reference style it is preserved. Do that.