12 Replies Latest reply on Sep 9, 2016 11:58 AM by ryanskihead

    Problem with builds

    Morten_Hjort Level 1

      Two months ago we finished and published an app to the PlayStore. We were using SweetAlert2 as a dialog box, but a month ago we removed it. The problem is we cannot build it right now and get this message Error - Your Android signing key is locked.  We have tried everything is in the documentation. The certificate and keystore passwords are correct. I have to mention the only modification from the working version is SweetAlert2 code removed.

       

      The app ID is: 1950333

        • 1. Re: Problem with builds
          ryanskihead Adobe Employee

          So you're saying you're unable to unlock your signing keys? What happens when you go to your account settings - Signing Keys, and unlock one? Does it change to the unlocked state?

          • 2. Re: Problem with builds
            Morten_Hjort Level 1

            No, it doesn't change the state

            • 3. Re: Problem with builds
              ryanskihead Adobe Employee

              I'm unable to reproduce this. Android signing keys seem to be unlocking and building fine in multiple test accounts.

               

              - Try deleting your signing key from your account and re-uploading it.

              - Note that Android signing keys remain unlocked for only one hour, when they will automatically re-lock. This is standard on build for production signing keys.

              - Ensure your app has the appropriate key selected for use.

              • 4. Re: Problem with builds
                Morten_Hjort Level 1

                I deleted the old signing key and uploaded a new one. On this one, the state has changed to "unlocked", but when I try to rebuild the app I get this error Error - Your Android signing key is locked.

                • 5. Re: Problem with builds
                  kiwinewt

                  I am getting a similar issue. I unlock my android signing key OK, but when I go to do a build it says that it is locked.

                  • 6. Re: Problem with builds
                    kiwinewt Level 1

                    Ahh, my problem is being a collaborator I have to have the owner unlock the keys to run a build...

                    • 7. Re: Problem with builds
                      shrt13

                      I have a similar issue with a brand new build.  Zip file uploaded with no errors.  Sign key uploaded with no errors to account.  I am the account owner and validated the password.  The password and the certificate and the keystore are the same.  When going to the account settings it allows me to unlock and states you have 1 hour usage.  I go back to the app in question select the sign key then select rebuild.  When it is done i get, "Error - Incorrect keystore password - You can fix this here".  click on here takes me to Support | PhoneGap Docs .  Password validated by using >keytool -list -keystore my_keystore.keystore.  How can my password be incorrect when it is unlocked in account settings?   Any help would be appreciated.

                      • 8. Re: Problem with builds
                        ryanskihead Adobe Employee

                        When you unlock your keystore, build doesn't actually test the keystore password, it just temporarily stores it. It's not until the build goes through that the password gets used by jarsigner. Tough to diagnose, thats simply what the signing tool responds With.

                         

                        Any special charactrers in your password?

                        • 9. Re: Problem with builds
                          shrt13 Level 1

                          Yes I had a special character in the password.  However that was not the issue, but you did give me an idea to try.  Thanks. 

                          Here is what i did to fix the issue.

                          1. Do not unlock your key in your account settings.  Leave it locked.
                          2. Select sign key
                          3. Fill out passwords
                          4. Click submit
                          5. Click Rebuild
                          6. Worked with both special character in password and without.

                           

                          My guess is that it is trying to pull from the account setting page but is not getting the information.  By leaving it locked in the account page you are forcing it to pull from your input not the account page.

                           

                          Again thanks.

                          • 10. Re: Problem with builds
                            dovt86692783

                            I have the same issue. Any idea how to resolve? I tried 10 different keystore files and many passowrds...

                            • 11. Re: Problem with builds
                              shrt13 Level 1

                              Try the following.

                              Go to your edit account page (drop down by image icon) (//build.phonegap.com/people/edit)

                              Select the Signing Keys tab

                              Ensure all keys are locked (lock button on right should be yellow)

                                   if not lock by clicking the button

                              click back to your apps page (//build.phonegap.com/apps)

                              Click the title of the app you want to sign (apps/######/builds)

                              select the key in the drop down

                              wait for error to show

                              click the yellow lock

                              Enter passwords

                              click rebuild

                               

                              My issue was that I was thinking unlocking from the account page would unlock global.  But it gets lost.  Once I unlocked at the apps page I had no issues.

                               

                              Hope this helps.

                              • 12. Re: Problem with builds
                                ryanskihead Adobe Employee

                                Note that if you are working on an app as a collaborator, you can't lock / unlock the signing key (it uses the one set by the app owner). Will update the UI to make this more clear.