12 Replies Latest reply on Jun 27, 2016 6:42 AM by karenw46452471

    Hebrew font spacing problem


      Hi, I'm using InDesign CS6 ME for Hebrew typesetting, currently working on multilanguage documents with Hebrew-Spanish/Hebrew-German. In some of the documents the characters are separating with extra 'space' appearing between the characters, although there's not actually a space there. It's happening in both languages, even though each language uses different fonts and have different style settings. I've tried changing all the style settings, ME character settings, have reinstalled InDesign, redone the documents from scratch, and initially the spacing corrects itself, but when I reopen the document the next time it's back.  We've been typesetting Hebrew for many years now without this issue and are using the same fonts and same USFM origination file. Anyone had similar problems and can recommend a solution?


        • 1. Re: Hebrew font spacing problem
          Peter Spier Most Valuable Participant (Moderator)

          Sounds like the text might be set to justified to fill the full width of the column. That could cause the letter spacing to change.

          • 2. Re: Hebrew font spacing problem
            karenw46452471 Level 1

            Thanks Peter. The text is right justified (Hebrew) left justified (Spanish) but not full width justified. And it is doesn't happen with every paragraph, just odd ones, and they can vary each time. I thought it may be something to do with kashida widths so have turned that off but still have the same problem.

            • 3. Re: Hebrew font spacing problem
              Ericadyson Level 1

              Hi.. yes.. I have quite a few problems with kerning and spacing in Cyrillic

              and right to left languages!



              *Erica Dyson אריקה דייסון *

              Erica Dyson Document Services

              [personal info deleted, forum policy]

              • 4. Re: Hebrew font spacing problem
                TᴀW Adobe Community Professional & MVP

                A screenshot of the problem page (the entire page please, not just a closeup of the problem), showing hidden characters as well, would be helpful.


                For the Hebrew, obviously you're using the Adobe World-ready Paragraph Composer.


                This definitely has some bugs, and, wherever possible, it's best avoided (but for RTL obviously it's necessary).


                Some of those bugs do include causing funny spacing. This is especially true when special characters are also used, anywhere on the page (not even just in the same paragraph). So a screenshot will be helpful.



                • 5. Re: Hebrew font spacing problem
                  Willi Adelberger Most Valuable Participant

                  A screenshot of the Justification Section of the used Paragraph Style would also help to solve the problem.

                  • 6. Re: Hebrew font spacing problem
                    karenw46452471 Level 1

                    Hebrew error justification.jpg

                    Hi, this shows how the spacing is off in the Hebrew and Spanish. On this page the spacing occurs mostly at the start of each line in both languages. On other pages it's in odd words in the Hebrew text below the rule. Justification settings for the Hebrew paragraphs are shown on the left.


                    Spanish error justification.jpg

                    And this is the Spanish justification settings for general paragraphs - such as the top two paras in the left column. Again spacing is odd at the start of the lines in the Spanish.




                    • 7. Re: Hebrew font spacing problem
                      karenw46452471 Level 1

                      And here's one with hidden characters on. Thanks!

                      with hidden characters.jpg

                      • 8. Re: Hebrew font spacing problem
                        TᴀW Adobe Community Professional & MVP

                        So, you can see in the last screenshot (with the hidden chars), in the Hebrew, that it's got these weird blue triangle-looking characters. It's a little hard to identify from this screenshot what they are, but my hunch is that if you were to delete them, both in the main text and in the footnotes, the spacing would go back to normal. (Just check that you don't actually need them -- I'm not sure what they are).


                        It's exactly these sort of special characters that can mess up the World-Ready composer, and cause the sort of thing you're seeing.


                        That's it from me for today -- it'll be candle-lighting time soon...


                        Shabbat shalom,


                        • 9. Re: Hebrew font spacing problem
                          karenw46452471 Level 1

                          Thanks Ariel, much appreciated, I'll give that a try.


                          • 10. Re: Hebrew font spacing problem
                            [Jongware] Most Valuable Participant

                            Can those sideways triangles be Right To Left Marks? They look ever so slightly different than when I insert one in an existing document, but that may just be the original image resolution.


                            Check by selecting one of them as text, and look in the Info panel for their Unicode. If they are U+200F, then it should be safe to remove them – right? InDesign does not need them in a paragraph that's already been set to use RTL.


                            You can globally replace them using the Find/Change panel in plain text mode. Search for "<200F>" (sans quotes, but including the angled brackets). Check if you need to replace them with a space or with 'nothing' (they may already have a space 'below', invisible here because the mark is drawn over it).

                            • 11. Re: Hebrew font spacing problem
                              Peter Spier Most Valuable Participant (Moderator)

                              Contrary to your statement above, your screen shots clearly show the text as justified*. The minimum and maximum spacing settings seem tighter than normal, and I wonder if they are being violated since your columns are a bit narrow for the type size and there is no hyphenation. You can turn on the highlight for that in the Composition section of the prefs, and it would be useful to see it.


                              *ID's alignment names are a bit inconsistent and confusing. In this dialog, Left means the left margin is straight and the text is ragged on the right. Left Justified means both margins are straight and the last line is left-aligned, ragged right. You can figure out the meaning of the rest from there.

                              • 12. Re: Hebrew font spacing problem
                                karenw46452471 Level 1

                                Hi, thank you all for the suggestions. I've increased the min and max settings for justification and turned on the violation highlighting . It was all bright yellow on the original settings... In many cases the changes to justification settings has resolved things. I've also deleted all the irrelevant back coding where I found it, including unnecessary right to left markers and cross reference callers that aren't needed. There are still odd places though where the text spreads out in certain words, but it is much improved and a minimal spread compared to previously. Not perfect, but almost there. Thanks for your advice.