3 Replies Latest reply on Jun 28, 2016 9:27 AM by kerrishotts

    Problem with App

    tomk82742553

      Hi All,

       

      I have a problem with my Application. I build my app in the Phonegap Desktop app ( With the plus icon ). The app is working on my computer browser, but when i'm uploading it to Phonegap build, and testing it on my mobile device i get the normal "Phone Device Ready" application, and not my own application.

       

      What's wrong, and how can i fix this?

       

      Cheers,

       

      Tom!

        • 1. Re: Problem with App
          kerrishotts Adobe Community Professional

          What are you uploading to PhoneGap Build? Keep in mind that PGB's project structure is not identical to the structure used by the Desktop app or the CLI.

           

          A CLI/PG Desktop App structure looks something like this:

           

          project-root/

              config.xml

              www/

                  index.html

                  js/

                      index.js

              res/

                  splash/

                  icon/

           

          Whereas a PGB app should look something like this:

           

          project-root/

              config.xml

              index.html

              js/

                  index.js

              res/

                  splash/

                  icon/

           

          Note that because the location of config.xml relative to assets has changed, you'll need to update the config.xml file appropriately.

           

          Hope that helps!

          • 2. Re: Problem with App
            tomk82742553 Level 1

            Hi,

             

            Thanks for answering! I created the application with the Phonegap Desktop App. The structure it created is the following:

             

            project-root/

                config.xml

                www/

                    index.html

                    js/

                        index.js

                res/

                    splash/

                    icon/

             

            When i'm uploading it i see the good title of the application, but the app itself isn't working. I only see the standard "Device Ready" application. Do you know what's wrong, and how i can fix it?

             

            Cheers,

             

            Tom!

            • 3. Re: Problem with App
              kerrishotts Adobe Community Professional

              The PG Desktop app structure will not work with PhoneGap Build. You'll need to adjust the structure by hand if you want to use PGB. You'll also need to alter config.xml to correctly reference any icons/splashes.

               

              (I know, it's a pain right now. I imagine it won't be that way forever...)

               

              Also make sure that the files you are editing are in the project's www, not a platform's www (since those can be overwritten).

               

              Furthermore, when you upload a project to PGB /do not/ include any platform or plugin specific folders (that is, "project-root/platforms/*", or "project-root/plugins/*") -- this can confuse PGB as to which index.html it should use.