8 Replies Latest reply on Jun 29, 2016 1:19 PM by dj_paige

    Problem with collections, history and files name on Lightroom 5.7

    giampierod73856103

      Hi,

      after a while, I decided to organizing  my catalog., I did EVERYTHING IN LR,

      I organized all years from 2007 to 2014, since 2015 and 2016 were already pretty good.

      Then I created a back up to a new HD, so that to have one more copy, so I exported any folder, year by year as a catalog.

      Now after that, on my catalog,some  collections count ZERO, other have just few pictures..when before had more than 100..

      history disappeared from ALL THE PICTURES OF ANY year, except ON 52 FOLDER OF 53 OF THE 2015, in any folder the only thing write on history is  the date of IMPORT??? 20-06-2016, that date should be at least the date of back up.

       

      One more issue, on a different Hd, I have the 2016 with recent travels, I organized all very well, and a that time, in LR, i decided to rename correctly every subfolder

      with the name of the location. after that happened that when i connect the hd, lr doesn't meet any photo,all the photos have a different name and an exclamation mark, the folder doesn't get question mark at all,  and if I want them back, I have to do it manually (ALMOST 10000 PHOTOS) since the option "FIND NEARBY MISSING PHOTO"  doesn't work!!!

       

      Hope that someone are able to understand my bad english first and then even my issues, and possibly  help me to solve them.

       

      p.s.

      LR 5.7 64 BIT

      Windows 10

      HD Toshiba 1tb; Seagate 2tb; Samsung 500gb

       

      Thank You

      GP

        • 1. Re: Problem with collections, history and files name on Lightroom 5.7
          dj_paige Level 9

          giampierod73856103 wrote:

           

          Then I created a back up to a new HD, so that to have one more copy, so I exported any folder, year by year as a catalog.

          Now after that, on my catalog,some  collections count ZERO, other have just few pictures..when before had more than 100..

          history disappeared from ALL THE PICTURES OF ANY year, except ON 52 FOLDER OF 53 OF THE 2015, in any folder the only thing write on history is  the date of IMPORT??? 20-06-2016, that date should be at least the date of back up.

          Explain exactly what you did to create the backup. Every step. Leave nothing out. Also please explain clearly what catalog has the zero collections, is it the original catalog or the backup?

           

          One more issue, on a different Hd, I have the 2016 with recent travels, I organized all very well, and a that time, in LR, i decided to rename correctly every subfolder

          with the name of the location. after that happened that when i connect the hd, lr doesn't meet any photo,all the photos have a different name and an exclamation mark, the folder doesn't get question mark at all,  and if I want them back, I have to do it manually (ALMOST 10000 PHOTOS) since the option "FIND NEARBY MISSING PHOTO"  doesn't work!!!

          You obviously have done this folder rename outside of Lightroom using your operating system. I think the easiest way to fix this problem is to go back to your operating system, and un-rename the folders so that they have their original names. Then, once this works and all photos are no longer missing in Lightroom, use keywords or other metadata (not folder names) to identify the contents on the photos.

          • 2. Re: Problem with collections, history and files name on Lightroom 5.7
            giampierod73856103 Level 1

            Hi dj_paige,

            straight to the point, to create the back up I only by a new hd, Seagate 2tb, first I organized files in LR as explained above,

            once all the files were organized per Yer and ready, I plugged the Hd on my laptop and then right click on the year: exported this folder as a Catalog, starting with the 2007 then 2008, and so on till 2015.

             

            The catalog that has a collection with zero or few files is the Original one, actually the only one I ever used, before that, I decided

            to back up all my archive as Catalog,

            Now I have the main catalog, on my laptop, well organized but with the problem underlined at the first post, and then I have the rest.

            catalogs by Years, 2007,2008 etc..on my new HD.

             

             

            About the folder name, NO,NO, I didn't rename any folder out of LR, 100% sure. all the folders were named at the time I was travelling, the folders had and have the same names on LR and on Windows;

            but a week ago, since I was arranging anything inside LR, I decided to rename the files of any single folders with the folder's name.

            That's all!!

             

            I do apologize, but I am still trying  to understand how the catalog works, I am getting crazy,

            However,I  hope that the explanations above are  clearer than before.

             

            Thank You very much for your time

            • 3. Re: Problem with collections, history and files name on Lightroom 5.7
              dj_paige Level 9

              Did you at any time re-import the photos? Did you at any time delete photos from Lightroom? Are the collections in these backup catalogs?

               

              Is it possible that you accidentally opened the wrong catalog file and that's how you have a catalog with zero in the collections? What happens if you search your hard disk(s) for all files whose name contains .LRCAT and open each one, do you find the catalog wit hthe proper number in each collectioN?

               

              Side comment, you've made a whole lot of work for yourself by exporting catalogs by folder (year), you should just back up the entire catalog file in one operation using the built in Lightroom catalog backup feature. You can make backups of your photos using your operating system, just drag the entire heirarchy of folders containing your photos to the external HD.

               

              but a week ago, since I was arranging anything inside LR, I decided to rename the files of any single folders with the folder's name. That's all!!

              Again, I need you to describe in detail how you did this. Again, I recommend you NOT do this in the future, as it makes your backups incomplete because now the proper backup file has a different name. Again, I recommend you add metadata like keywords to the photos to achieve this task so that the folder names and file names are unchanged.

              • 4. Re: Problem with collections, history and files name on Lightroom 5.7
                giampierod73856103 Level 1

                First answer:

                No, I didn't re-import any photo at that time and not even later

                Second:

                I do not know, I always oped the last backed up catalog, but one thing I have to say,

                before starting all this mess, when I back up the catalog, I always got a catalog around 4.5 GB, after that i have  lighter one, 2.20;2.50 GB

                I do the back up of the catalog every week with the LR given feature, this time I was doing the back up of the archive,

                and as also Adobe suggests, I did it with the LR feature " export this folder as a Catalog".

                Since the Catalog I use has around 50000 photos, I thought that could be good work with something lighter

                 

                I tried an old catalog saved a month ago and there, I found one of the collections, it was complete with 30 photos.

                 

                last point

                To rename all the files(PHOTOS) I simply select all photos in every single folder and then f2, custom name as "date_name_original file name"  ALL IN LR.

                Normally I do it during the import from the camera to the HD, always in LR,, this time I wanted just be a bit more precise with the name..and I did it in Library module.

                 

                That's all,

                 

                below two screen shots of the same folder, one in LR, the other on my HD.

                 

                Thank You

                 

                HD files names.jpg

                 

                 

                LR files name.jpg

                • 5. Re: Problem with collections, history and files name on Lightroom 5.7
                  dj_paige Level 9

                  and as also Adobe suggests, I did it with the LR feature " export this folder as a Catalog".

                  I have never seen Adobe suggest doing this for the purposes of backup, and I do not recommend this at all. Extra work, no obvious benefit.

                   

                  Since the Catalog I use has around 50000 photos, I thought that could be good work with something lighter

                  Something smaller has no benefit, it's as I said, just extra work to create.

                  I tried an old catalog saved a month ago and there, I found one of the collections, it was complete with 30 photos.

                  So you can recover your collections using the command File->Import from Another Catalog and point to this particular catalog. Did you find backups with the rest of your collection information?

                   

                  Your screen captures show the problem clearly. In Lightroom, the photo is named IMG_7343.CR2. Your operating system shows a different name. So Lightroom cannot find the photo, and as far as I know, these would have to be reconnected one by one. (If you have backups of your photos with the original names (similar to IMG_7343.CR2) then you could copy the backups to this folder and Lightroom would recognize them.

                   

                  I still can't explain how you got to this state of affairs, something doesn't quite fit, the symptoms you have indicate things are being changed outside of Lightroom, but you claim that you have never done so. The symptoms you have also could be because you have accidentally opened the wrong catalog, you need to use your operating system's search feature to find all files whose name ends with .LRCAT and then open each one until you find the one that has everything properly working. If you have a recent backup of your catalog file before these problems started, you could probably make use of that.

                   

                  And to repeat earlier suggestions, organize using Lightroom tools like metadata (keywords, captions, titles) and not using operating system constructs such as file names and folders, and you will most likely not have these problems in the future.

                  • 6. Re: Problem with collections, history and files name on Lightroom 5.7
                    dj_paige Level 9

                    One other thought occurred to me

                     

                    Do you sometimes open Lightroom by double-clicking on the Lr icon, and other times Lightroom automatically opens when you insert a camera card into the card reader or when you attach a camera to the computer via USB cable?

                    • 7. Re: Problem with collections, history and files name on Lightroom 5.7
                      giampierod73856103 Level 1

                      I got the point, for the Future, I already set the way, for now I will follow Your suggestions.

                       

                      now my last question is about history.

                       

                      Why I cannot find the history of all files? Have You any suggestions?

                       

                      P..s

                      About your last post, I used to open LR at the same moment I insert a card reader,

                      But ultimately, I am opening it with double click on it.

                       

                      Thank You once again for Your precious time, much appreciated.

                       

                      Best

                      GP

                      • 8. Re: Problem with collections, history and files name on Lightroom 5.7
                        dj_paige Level 9

                        About your last post, I used to open LR at the same moment I insert a card reader,

                        But ultimately, I am opening it with double click on it.

                        This could mean you are opening two different catalogs, one which has the renamed photos and one which doesn't.

                         

                        Try opening LR both ways, and see if there are really two different catalogs being opened.