3 Replies Latest reply on Jul 4, 2016 1:53 PM by spiteyourface

    AE won't import .swf from current Animate, Error (18 :: 1)

    spiteyourface

      Like the title says, running AE 2015.3 and Animate 2015.2 from a fresh new install of the CC package on a Mac Pro running 10.9.5

       

      AE won't import .swf files generated in latest version of Animate. I've tried various publish settings and created fresh test documents to export from, but no joy. Every time I get

       

      After Effects Error... unsupported file type (18 :: 1)

       

      These are brand new files created on a fresh install. I can import legacy .swf files, ie ones created in older versions of Flash (probably CS4 or 5.5 ) but not new .swf files.

       

      The only exception, which makes no sense, is if I move or publish the files to the desktop. If the files are on the desktop they open fine. Otherwise, no joy.

       

      The files are simple vector illustrations or key animations. No scripting etc.

       

      Any ideas?

        • 1. Re: AE won't import .swf from current Animate, Error (18 :: 1)
          spiteyourface Level 1

          Nobody know? I should be able to import between software on a new version? I'm on a deadline so would appreciate the help, plus if I can't import .swf files into AE anymore (as I've been doing for over a decade) then my little world falls apart.

           

          The fact that they can be read only if saved/moved directly to the desktop is surely the key to the (18 ::1) error message? Even an encapsulating folder on the desktop and they still don't work. Only the desktop itself. So is it a permissions thing?

           

          I've already run the Cloud Cleaner and Limited Access Repair tools. CC isn't showing any other errors or limitations, just this one debilitating (for me) bug.

          • 2. Re: AE won't import .swf from current Animate, Error (18 :: 1)
            Rick Gerard Adobe Community Professional & MVP

            Importing SWF files has always been a buggy proposition. Make sure AE and Animate are both up to date. If they are and your files do not work try creating a simple SWF file that only has one animated shape then try importing that. If that doesn't work then file a detailed bug report.

             

            I would suggest that you create a video from your SWF and import that.

             

            What exactly are you trying to do? SWF to AE to Video is not usually a good workflow.

            • 3. Re: AE won't import .swf from current Animate, Error (18 :: 1)
              spiteyourface Level 1

              swf to AE to video is a workflow I have been using regularly for 12 years or more, is a mainstay of infographics and character animation, and has generally been reliable for me. Anything involving rasterization is not an option for me.

               

              As the op states I'm all up to date and have tried creating test/dummy files in every export/publish iteration I can fathom.

              Disabling "write XMP IDs to Files on Import" has no effect.

               

              The problem is still persistent and still urgent.

               

              I've since installed Flash CS6 via CC's legacy install options, and tried exporting swf files from both Flash CS6 and Animate CC.

               

              Consistently, importing files generated to or moved to the desktop is the only option that works (but is not a solution for me).

               

              The only swf files I can import from other locations are archived legacy files that were generated under older circumstances, either because they were generated under a different license or using an older OS, but this is speculation.

               

              What aspect of permissions/user etc might possibly be affecting the legibility of newly created swf files? Why is it creating the (86 :: 1) error, and why only swf files? I know Flash has been disavowed, but they continue to release Animate with swf as a mainstay export option.

               

              I've filed a bug report, tried full reinstall of CC, used cleaner tool, but no errors are detected and nothing changes...