1 Reply Latest reply on Jul 5, 2016 11:42 AM by kerrishotts

    Inappbrowser not opening images from external sources

    joaos56004180

      Hello,

       

      I have an issue that is doing y head in! I had an app built with Phonegap and had the need to update some plugins but after that some images that i was loading from external sources just stopped loading i have made no changes to code in index.html or config.xml. The weird thing is that still loads images from other sources but from a specific server stopped all together.

      My config.xml

      <access origin="*" />

          <plugin name="cordova-plugin-whitelist" version="1" />

          <allow-intent href="http://*/*" launch-external="yes" />

          <allow-intent href="https://*/*" launch-external="yes" />

          <allow-intent href="tel:*" launch-external="yes" />

          <allow-intent href="sms:*" launch-external="yes"/>

          <allow-intent href="mailto:*" launch-external="yes"/>

          <allow-intent href="geo:*" launch-external="yes"/>

          <platform name="android">

              <allow-intent href="market:*" launch-external="yes"/>

          </platform>

          <platform name="ios">

              <allow-intent href="itms:*" />

              <allow-intent href="itms-apps:*" />

          </platform>

      Inappbrowser version 1.4.0 and whitelist version 1.2.0

      here's an example of an image i am trying to load http://media.continente.pt/Sonae.eGlobal.Presentation.Web.Media/media.axd?resourceSearchTy pe=2&resource=ProductId=2691548(eCsf$RetekProductCatalog$MegastoreContinenteOnline$Contine nte)&siteId=1&channelId=1&width=150&height=150&defaultOptions=1 Like i said i had no issues at all in the past and if i try to open the same file with chrome everything works fine!

       

      Any idea?