2 Replies Latest reply on Jul 5, 2016 2:32 PM by jims15779625

    Non-hex character when saving PDF.

    jims15779625 Level 1

      Using Adobe Acrobat XI Pro, I have created a PDF by combining other PDF files. When I try to save it I get this error:

       

      The document could not be saved. There was a problem reading this document (117).

       

      When I CTRL-click on OK, it gives me this error:

       

      Non-hex character in a hex string.

       

      Does anyone know what's causing this error? I just want to save it!

        • 1. Re: Non-hex character when saving PDF.
          Karl Heinz Kremer Adobe Community Professional

          Chances are that one (or more) of your source documents is corrupt. You can try to open each one of them, and then trying a "File>Save As" operation. You will very likely get the same error message with at least one of these files.

           

          The problem is that a "hex string" (which is a string of characters that only consists of the characters 0-9 and A-F) contains a character that is not one of 0-9 or A-F. This is a syntax error in the PDF file, and Acrobat cannot save that file.

           

          When you combine files, or when you do a "Save As", Acrobat will re-create the complete PDF hierarchy from scratch, and when it finds something that it cannot process, it throws the exception you have seen. This is different from doing just a "Save" after a modification, because in that case, Acrobat will leave the original file intact, and will only add an incremental update at the end of the original PDF file.

           

          You will have to identify which file is causing the problem, and then only combine the files that are not corrupt. You can try to find out which page iin the corrupt PDF file is triggering the error, and then e.g. remove that one page and replace it with a recreated page.

          • 2. Re: Non-hex character when saving PDF.
            jims15779625 Level 1

            Thanks for the advice Karl. Unfortunately I do not want to lose the files which may be causing the problem.

             

            I did find a solution (not so satisfactory, but it will do for now): I turned off optimizing for fast web view in the preferences. Here's my steps for anyone else with this problem:

             

            1. Edit->Preferences.

             

            2. Documents category -> Save Settings.

             

            3. Uncheck "Save As optimizes for Fast Web View"

             

            This has the significant disadvantage of making the file-size much bigger than it could be.