1 Reply Latest reply on Jul 6, 2016 5:18 AM by Steve Grisetti

    Problem running Premiere Elements under Windows 10 with Matrox Codecs

    davids13573494

      I cannot get Premiere Elements 12 to run under a clean installation of Windows 10 with Matrox Codecs loaded.   After starting PE and selecting Video Editor it hangs while ‘Loading Exporter AVI.prm’. It worked fine under Windows 7 and continued to work when I updated to Windows 10.  The problem arose after going for a clean installation of 10 following a motherboard failure.

       

      I need to use the Matrox Codecs because I have a number of videos from old cine film which I want to edit and these are .avi files which use a Matrox Codec.

       

      I have tried a trial copy of PE 14 and that won’t work either.  Nor will either 12 or 14 work on another PC running windows 10 ungraded from 7, a PC which has not previously had PE installed. I wonder if some setting(s) were carried over from Windows 7 to 10 when I upgraded.

       

      Has anyone any suggestions what else I could try?

       

      Loading Premiere Elements and then the Matrox Codecs results in PE ‘hanging’ after selecting ‘Video Editor’ then ‘New Project’.

       

      The .avi files are high definition (1920 x 1080) files, I think in the Matrox I-Frame .avi codec.