0 Replies Latest reply on Jul 8, 2016 3:45 AM by hepapp

    [BUG?] "Remove hidden information"-Tool rasterizes pdf document

    hepapp

      Hey there,

       

      I'm trying to reproduce a bug with other users, which Adobe says they cannot reproduce themselves. I can reproduce the bug on four different machines, both Windows (8.1 and 10) and Mac, all running with the current Acrobat DC.

       

      Problem: When I use the "Remove hidden information"-Tool to remove text and/or vector elements that are covered by bitmap images, the tool rasterizes the entire document (at poor quality, too) instead of just removing the underlying information (text and or graphics).

       

      The only "discussion" of this bug I could find was in this old thread: Bugs in document sanitizing (Protect PDF)

      In certain cases, the "Remove hidden information" function will rasterize a document: This happens if you have information that is partially covered up by other objects, and it is not possible to remove the hidden information in any other way.

      My problems are:

      a) this isn't communicated anywhere, either in the gui or the relevant help page: Removing sensitive content from PDFs in Adobe Acrobat DC

      b) while there are checkboxes for literally every detailed type of element to be removed, there is no checkbox to say "remove objects that result in rasterization of document"

      c) With the identical sample documents, Adobe support did not have the problem. Moreover, with some documents the bug only appears every other time I run the identical set of commands.

       

      With the following Testdocument (Dropbox - test document )

      - When I run the tool and save the document, this rasterized version is the result: Dropbox - test document with bug evident

      - But if I click the "Edit Object"-Tool, right after the process, then save the document (but do not close the "remove hidden information"-sidebar first), then the process works as excpected: Dropbox - test document without bug, as it should be

      This seems like a bizarre workaround, but unfortunately this doesn't prevent the bug with the more complex documents I am actually working on.

       

      Hence:

      - Is it really just me, on four completely different machines (as Adobe claims)?

      - Has anyone else encountered this bug before (and possibly found a workaround)?