2 Replies Latest reply on Mar 25, 2009 4:17 AM by emerys

    cfc error when using Flex and RemoteObject (cross post)

    Level 1
      I have Flex 3.0.214193 and CF 8,0,0,176276 and Oracle
      I've been search for several days for an answer to this one. There is very little out there about this type of error, but then there is very little about any problems with Flex and ColdFusion.
      In Flex, I have two comment fields. the .cfc has two update functions that update the comments, because they are in two different tables. The first update works like a champ. The second one consistantly shows this error in the CF application log: The NEWENGREMARK parameter to the updateEng function is required but was not passed in. I've used the Alert.Show to verify that Flex does have a value in that variable when it calls the .cfc. I've even tried passing the first variable that worked in the first update, and even a litteral value. Everything yields the same cryptic error message. I must be looking at the wrong thing.
      The only things I've found on the web about this, say the variables should have a scope (is that a scope in Flex or in the .cfc) and the column names should be in upper case (because it's Oracle).
      Here's the .cfc code (is that where the error is, or is it in Flex?). The UpdateDescription function works, but the UpdateEng doesn't.

      Thanks for any help, or spelling errors you can point out.
        • 1. Re: cfc error when using Flex and RemoteObject (cross post)
          Level 7
          emerys wrote:
          > <cffunction name="UpdateDescription" access="remote" returntype="string" >
          > <cfargument name="newDescription" required="true" type="string">
          > <cfargument name="descriptionUpPK" required="true" type="string">
          > <cffunction name="UpdateEng" access="remote" returntype="string" >
          > <cfargument name="newENGRemark" required="true" type="string">
          > <cfargument name="engUpPK" required="true" type="string">

          Wild shot in the dark. Triple check the case of your parameters names.
          I remember there can be some funky business with the cases of variable
          when data is going between ColdFusion and Flex.

          You may want to experiment with different cases as well. It may not be
          intuitive on what they should be.

          Thirdly. Can you simplify the second function to use know
          <cfargument...> tags and then just dump the argument scope someplace for
          • 2. Re: cfc error when using Flex and RemoteObject (cross post)
            Level 1
            I also heard about the case thing. So I tried everything in upper case and lower case - same thing. In my experimenting, I tried adding the newENGRemark parameter to the descriptionUpdate function call, I didn't do anything with it is the .cfc just declared it as required. In that case the parameter exists and everything is fine. But in the call to the UpdateEng, it doesn't exist.
            I changed the .cfc so that the newENGRemark was not required or had a default. In both cases the .cfc just skipped to the next parameter and said it didn't exist. But I was passing a litteral, it wasn't even a variable.
            I created a .cfm page that did a cfinvoke on the .cfc, and passed it two litterals. That worked fine. So that makes it look like some sort of syntax error in the Flex. So I deleted the call to the UpdateENG, copied the UpdateDescription call (because it works), changed just the minimum to make it work, but it didn't work.
            I think I am going to restructure the database so that I can do what I need to with just one update function, that seems to work.
            It still doesn't make any sense.
            Scott (Flex code is attached)