1 Reply Latest reply on Jul 10, 2016 5:58 PM by patrickp0208

    Trying to update LR6.3 to 6.5.1 - keep getting error message [was: patrickp0208]

    patrickp0208

      I have LR6.3 stand alone and want to update to version 6.5.1 (compatible with Nikon D5). I keep getting an error window when I want to download the update. Does anybody know how to proceed efficiently?
      Thanks.