0 Replies Latest reply on Jul 11, 2016 9:59 PM by 0000hackofalltrades

    Post render action, importing rendered frames then rendering a quicktime does not work in AE CC2015 and above

    0000hackofalltrades

      Hey guys,

       

      Seeing a few somewhat similar questions in the FAQ. But haven't seen a definitive answer yet.

       

      I currently have to bounce back and forth between AE CC2014 and CC2015 do to a couple of different render workarounds....

       

      CC 2014 does not appear to want to render audio in quicktime movies. No matter what flavor of codec I use or what species of audio compressor, it just will not finish rendering the movie.It gets all the way through the render, then fails at the last moment saving the file with audio. When I turn off audio, no problem. Quicktime finishes with no errors.

       

      CC 2015 renders audio just fine! So.. if I have a project using audio I render from 2015, luckily they are interchangeable.

       

      However, my standard render set up is the following,

       

      I render numbered DPX frames out of AE via the command line render. The render cue is set up with a post render action to bring the DPX's back in and replace footage in a comp that is next in the render cue to render as a quicktime.

       

      This works flawlessly in CC2014. And has worked flawlessly for a large number of years going back to CS5 and possibly earlier.

       

      When I upgraded to CC 2015, the post render action stopped working. No matter what I do, it will not import the post render actioned DPX's and then render the quicktime. It only renders color bars for missing footage.

       

      If I open the project in the GUI, the frames have been imported/replaced and if I look at the timeline for the quicktime comp, the frames are there. But they only refresh when I open the GUI. Also, if I render in the GUI, (Tried this as a workaround) It still does not correctly swap out the rendered frames. But if I manually click on the frames, they refresh and everything's fine, I can fire off the render of the quicktime. It's highly frustrating.

       

      I find myself backtracking to CC2014 more often than not just because everything works. (Unless I need audio.)

       

      Is there some reason this no longer functions correctly?

       

      Oh, and I just checked, it's not fixed in the latest CC2015.3