9 Replies Latest reply on Jul 16, 2016 1:15 AM by charlieh6415140

    latest batch of Nikon RAW not shown

    charlieh6415140

      Over the last couple of weeks I have been experiencing problems.

      The first problem was that clicking on the image in develop to see it enlarged took a very long time - with the message "loading" showing

      yesterday I imported a batch of 98 Nikon RAW files (NEF)

      these are not shown in the Navigator view - what I see are plain grey rectangles but no error messages

      clicking on Develop does load the image and once i have done this the thumbnail image appears in Navigator

        • 1. Re: latest batch of Nikon RAW not shown
          Per Berntsen Adobe Community Professional

          Please provide some details -

          • Version of Lightroom (Help > About Adobe Photoshop Lightroom)
          • Operating system
          • Camera model

          Your problem might be caused by a corrupted monitor profile. This is quite easy to check for, see

          How do I change my monitor profile to check whether it’s corrupted? - The Lightroom Queen

          • 2. Re: latest batch of Nikon RAW not shown
            charlieh6415140 Level 1

            Sorry, obviously needed!

             

            Lightroom V5.7   camera RAW V8.7

             

            PC - running Windows 7

             

            camera Nikon D610

            • 3. Re: latest batch of Nikon RAW not shown
              Per Berntsen Adobe Community Professional

              Did you try setting the monitor profile to sRGB?

              Go to Control Panel > Color management.

              Click Add, then choose the sRGB profile, and set it as default profile, and check Use my settings for this device.

              If this fixes the problem, you should ideally calibrate your monitor with a hardware calibrator.

               

              color-management.png

               

              srgb-default.png

              • 4. Re: latest batch of Nikon RAW not shown
                charlieh6415140 Level 1

                No. No colour management tab in my control panel. Is it lower down in the structure of the panel?

                 

                I have been using LR for three years with no problem until the recently - so I doubt that a monitor setting can be the cause.

                 

                Another clue to the possible problem...

                 

                This morning I tried LR again, the problem still exists. When I shut down LR started backing-up the catalogue, as it does weekly. it failed with the message...

                "error when reading from preview cache

                LR will attempt to fix the problem next time it launches."

                 

                This failed.

                 

                Does LR use Shockwave or Flash - could a recent update of these be the cause of the problem? How do I put this right?

                 

                Chaz

                • 5. Re: latest batch of Nikon RAW not shown
                  dj_paige Level 9

                  I have been using LR for three years with no problem until the recently - so I doubt that a monitor setting can be the cause.

                  Unless the monitor calibration has become corrupted, which does happen to people. You need to check as described in the link provided above by Per Berntsen.

                   

                  This morning I tried LR again, the problem still exists. When I shut down LR started backing-up the catalogue, as it does weekly. it failed with the message...

                  "error when reading from preview cache

                  LR will attempt to fix the problem next time it launches."

                  This is completely unrelated to the problem in your original catalog, which still seems like the monitor calibration is corrupted.

                  • 6. Re: latest batch of Nikon RAW not shown
                    Per Berntsen Adobe Community Professional

                    "error when reading from preview cache

                    LR will attempt to fix the problem next time it launches."

                    In that case it's not the monitor profile, but a corrupted preview cache, which you have to delete manually.

                    With Lightroom closed, use Windows Explorer and go to the folder containing the LR calalog.

                    Delete (or, if you prefer, rename or move to someplace else) the folder called Lightroom Catalog Previews.lrdata

                    Do not delete anything else.

                    Now launch Lightroom, and the previews will rebuild as needed (as you browse images in Library)

                     

                    lockfile.png

                    • 7. Re: latest batch of Nikon RAW not shown
                      charlieh6415140 Level 1

                      Oh thanks for that. Sounds right. It certainly seems to make sense of the fact that the Navigator images don't work, but switching to develop and the image appears as it should. (if it was a monitor configuration problem both would be affected - wouldn't they?) I don't have time to do it tonight but should get it done tomorrow, Will report back after doing it.

                       

                      Chaz

                      • 8. Re: latest batch of Nikon RAW not shown
                        Per Berntsen Adobe Community Professional

                        Well, dj_paige's last post got me thinking, maybe it could be monitor profile after all.

                        A defective monitor profile can manifest itself in several ways, the most common being displaying no image at all in develop, or displaying wrong colors in develop, often accompanied by a yellowish or brownish cast on the histogram.

                        There are probably symptoms I haven't come across yet for a defective profile, but in your case the image did display in develop, but the Navigator didn't.

                         

                        So the problem is most likely caused by the preview cache, although I wouldn't rule out the monitor profile.

                        My guess is that when the problem occurred, Lightroom hadn't yet had the opportunity to give you the preview cache error message, it only does that when you launch the program, as far as I know.

                         

                        As for accessing the monitor profile, you can bypass the control panel by pressing the Windows key + R, typing colorcpl in the box, and hitting Enter. That will take you directly to the Color management dialog.

                        And monitor profile corruption can happen out of the blue - Lightroom is particularly picky about the monitor profile - a profile that Photoshop finds perfectly all right can cause Lightroom to act up.

                        One cause for monitor profile problems is that Windows updates install manufacturer's profiles - they are notoriously bad, and often defective right out of the box.

                        This is more of a problem with Windows 10 though - I have used Windows 7 for years, and the updates have never touched my monitor profile.

                        • 9. Re: latest batch of Nikon RAW not shown
                          charlieh6415140 Level 1

                          Well, I have to thank you for your help. I just implemented your advice, renaming the Lightroom Catalog Preview file and then launching LR. Worked a treat! There is a delay as each folder is opened while LR rebuilds the data, and this takes rather longer if the folder is full of RAW files - but that's a small price to pay for getting back full use of the program.

                          Again - many thanks - your expertise has rescued my photography!

                           

                          Chaz