1 Reply Latest reply on Jul 16, 2016 1:49 PM by John Waller

    Lightroom 6.0 for Olympus OM D EM 10 Mk2

    simony69363094

      I have hust purchased what I thought was latest version of Lightroom from John Lewis (together with new laptop) only to find out that min version of 6.2 is required to import .ORF files from my Olympus OM D EM 10 MK2. Seems that this is the only Olympus camera that requires this version, I have 6.0.

      What is the best way of getting 6.2, without laying out another liicence fee?

      I have already contacetd JL for help and await their reply.