3 Replies Latest reply on Apr 28, 2006 11:09 AM by Newsgroup_User

    gotoNetMovie

    jimacx37
      When I click on a link on my first page the link throws up a "Can't open file" error plus a double URL address of the linked file..hence it not opening. It works fine on my local machine over the internet but not on a machine outside work. The addy is http://www.ljmu.ac.uk/bie/forensic/lead.htm

      Anyone have any ideas please?

        • 1. Re: gotoNetMovie
          James Newton, ACP Level 3
          It looks like you are using:

          goToNetMovie the moviePath & "subfolder\movieName.dxr"

          On your machine, the moviePath will use backslash characters \. In Shockwave, you need to use forwardslash characters / as path delimiters.
          Alternatively, you can use...

          goToNetMovie "@\subfolder\movieName.dxr"

          ... and let Director convert the path delimiter characters for you.
          • 2. Re: gotoNetMovie
            Level 7
            > The addy is http://www.ljmu.ac.uk/bie/forensic/lead.htm
            >
            > Anyone have any ideas please?

            I gave it a try. It errored the first time through (seemed to simply
            stop - no error messages) but on a reload it worked in that I was able
            to click the 'Begin' button and it appeared to navigate to the next file
            (contents.dcr). When I clicked any of the items for investigation I
            invariably get the following error: 'unable to open file
            " http://www.ljmu.ac.uk/bie/forensic/%name%.lnk"'
            This appears to be an incorrect file name for gotoNetMovie (but may work
            for 'go(movieName)' if the link resolves properly). So, why is it trying
            to navigate to a shortcut instead of a dcr file? You might check the
            filename you're navigating to. Can you post a line of code? And are you
            sure you're using 'gotoNetMovie' and not something like '_movie.go(1,
            "movieName")'?
            • 3. Re: gotoNetMovie
              Level 7
              On Fri, 28 Apr 2006 10:19:24 GMT, jimacx37 posted in
              macromedia.director.lingo:

              > When I click on a link on my first page the link throws up a "Can't open
              > file" error plus a double URL address of the linked file..hence it not
              > opening. It works fine on my local machine over the internet but not on
              > a machine outside work. The addy is
              > http://www.ljmu.ac.uk/bie/forensic/lead.htm
              >
              > Anyone have any ideas please?

              I'm getting the same errors Sean reported. The first begin button works
              (didn't try the second begin button that appears above the first). But once I
              get in, all the links I tried are attempting to link to filenames ending in
              .lnk

              I suspect if you upload the actual .dcr files (not shortcut links) and change
              the links to point to .dcr files instead of .lnk files things will begin
              working for you.

              Why does it work from your local machine? I'm willing to bet that those .lnk
              files are pointing to a file on your local drives. I can't say for certain,
              though - I don't use them much beyond Desktop shortcuts.


              --
              Mark A. Boyd
              Keep-On-Learnin'