2 Replies Latest reply on Jul 25, 2016 9:27 AM by mihaj73682042

    Phonegap not opening links in system browser

    mihaj73682042

       

      I am new to PhoneGap and Cordova. I am trying to create an application for now just for personal purposes.

      The problem:

      When I run the app on the phonegap desktop I can easily open the links when I press the desired content (#first). But when I upload app on build.phonegap and then download the app on a phone it does not work anymore.

      Also I'm getting the error: Error initializing Cordova: Class not found


      Here is my content from github: https://github.com/unforgivenJ/Test

      And app for download: https://build.phonegap.com/apps/2182437/share

      Any help would be appreciated. Regards, Miha.

        • 1. Re: Phonegap not opening links in system browser
          VectorP Level 4

          Phonegap Build expects something different from what you are uploading:

          a. never upload platforms, plugins and other Cordova related directories

          b. only upload your assets and a config, where both index.html and config.xml must be in the root of your zip file. To get that done easily:

          - move config.xml into /www

          - adjust the paths in config (icons/splashes) accordingly

          - zip up only the contents - not the directory itself - of /www, now.

           

          BTW: this would be a perfect time to start reading the Phonegap Build documentation!

          Your app won't build/work properly, even after uploading a correct zip file, for instance because:

          - you have included references to both phonegap.js and cordova.js

          - you are using a density attribute with compound qualifiers for splashes

          - you are specifying older versions of most plugins

          - you included an 'engine' element in your config

          - you are making incorrect use of the inappbrowser plugin's interface functions.

          1 person found this helpful
          • 2. Re: Phonegap not opening links in system browser
            mihaj73682042 Level 1

            Hi, thank you so much for your help, now it works everything, thank you for slapping me in the face