13 Replies Latest reply on Mar 2, 2018 6:10 AM by ananthanj63180971

    "Event not covered" for transactional message

    hkurz Level 1

      I am trying to test transactional messaging (sending an email by SOAP request) to no avail.

       

      What i did:

       

      - created a template, type (called "t3") according to the steps in the documentation file "message-center-v6.1-en.pdf".

      - Created the event "t3"

      - published the template

       

       

      - sending a proof worked perfectly

       

      Then i created send SOAP message to the server with "Boomerang SOAP & REST client". This worked after using the content of a cookie "__sessiontoken" as "sessionToken".

       

      Request looks like this.

       

      <x:Envelope xmlns:x="http://schemas.xmlsoap.org/soap/envelope/" xmlns:urn="urn:nms:rtEvent">

          <x:Header/>

          <x:Body>

              <urn:PushEvent>

                  <urn:sessiontoken>___3a1ac7f7-8fc6-46fe-af52-db8f1865b60e</urn:sessiontoken>

                  <urn:domEvent>

                      <rtEvent xmlns="" wishedChannel="0" email="hermann.kurz@valtech.de" externalId="1749261730" expiration="2016/12/10 10:09:53" type="t3">

                          <ctx>

                               <commune>Poisson Ville</commune>

                          </ctx>

                      </rtEvent>

                  </urn:domEvent>

              </urn:PushEvent>

          </x:Body>

      </x:Envelope>

      l got back a response with HTTP code 200 (success) with this content:

      <?xml version='1.0'?>

      <SOAP-ENV:Envelope xmlns:xsd='http://www.w3.org/2001/XMLSchema' xmlns:xsi='http://www.w3.org/2001/XMLSchema-instance' xmlns:ns='urn:nms:rtEvent' xmlns:SOAP-ENV='http://schemas.xmlsoap.org/soap/envelope/'>

          <SOAP-ENV:Body>

              <PushEventResponse xmlns='urn:nms:rtEvent' SOAP-ENV:encodingStyle='http://schemas.xmlsoap.org/soap/encoding/'>

                  <plId xsi:type='xsd:long'>72057594037964936</plId>

              </PushEventResponse>

          </SOAP-ENV:Body>

      </SOAP-ENV:Envelope>

       

      In the event history of the message center i see the event (see screenshot), but it is marked as "Event not covered" and no email is sent.

      Screen Shot 2016-07-26 at 13.29.41.png

      I do not see any entry in any logfile i searched on the server for this event.

       

      Apparently the server cannot associate the request (type="t3") with the template for some reason. Event type of the template is "t3", as you see in this screenshot:

      Screen Shot 2016-07-26 at 13.34.23.png

       

      Server works OK for workflows, but just not for transactional messages via SOAP (proof sending works also). We are using a linux machine for the server.

       

      Additional info

       

      in the Audit log of the Workflow "Processing real time events" i see "[Routing] 1 message(s) with errors" (see screenshot).

      But i cannot find out what the actual error was. How is this done?

       

      Screen Shot 2016-07-28 at 15.39.17.png

       

      Does anybody know what's (not) going on here? Is there any place on the server where i can see what is going on?

       

      any help appreciated

       

      Hermann