4 Replies Latest reply on Jul 27, 2016 11:43 AM by felystar

    Problems with AMD Graphics, AE and Element3D

    felystar Level 1

      Hello guys, I've recently installed After Effects CC on a different system than usual and I have some problems with my graphics card and After Effects CC 2015 (13.5). First let me name the PC components:

       

      • Processor: i5-3230M (2.6Ghz up to 3.2Ghz)
      • Graphics Card: Intel HD 4000 and dedicated AMD Radeon HD8750M (1GB VIDEO RAM)
      • RAM: 4GB
      • OS: Windows 8.1 (64-bit)
      • OpenGL Version: 3.0.13399 (that's what After Effects said...) and 6.14.10.13399 (that's what my graphics driver said)
      • OpenCL Version: 1.2
      • AMD Graphics Driver Version: Catalyst 15.20.1062-150715a-187146C (I couldn't even open After Effects when using latest drivers, known as Crimson, a popup error appearing about a library number 67 (I think) wouldn't let me open it and I solved it by changing a .dll name in System32 and After Effects opened fine, but Element 3D kept saying OpenGL not availaible...)

       

       

      Here is the deal. I am trying to use Element3D (v2.2) and it works as long as i have installed Catalyst Drivers but it keeps saying I have 0MB Video RAM. I thought it was only this plugin which was having troubles with OpenGL, but I recently found out that I cannot check the option "Hardware Accelerate Composition, Layer, and Footage Panels" under Preferences -> Display..., however Fast Draft mode is enabled and under my GPU Info in Preferences -> Previews it says I have 2,97GB available for OpenGL, and Shadel Moder 4.0 or greater, so it means I have everything right for it to work properly but it simply doesn't. I thought maybe the thing about 0MB Video RAM and not being able to check Hardware Accelerate were kind of related, so solving one would solve the other.

       

      I said it before but just in case, I tried to use last version of AMD Crimson drivers but After Effects launches (after some tricks) but Element3D keeps saying OpenGL error ( http://i.imgur.com/rCqJWtj.jpg ).

       

      Thank you guys for you're time and hope you can give me a hand

       

      Kind regards,

      Felipe P.

        • 1. Re: Problems with AMD Graphics, AE and Element3D
          Mylenium Most Valuable Participant

          Disable the onboard intel graphics.

           

          Mylenium

          • 2. Re: Problems with AMD Graphics, AE and Element3D
            felystar Level 1

            Actually, I use Catalyst software to force After Effects to use the AMD one and it recognizes it in GPU Info... under Previews... and Element3D also appears to recognize it.

             

            Do you think that disabling one will make AE work?

            To be honest with you I don't know how to permanently disable the Intel one

            • 3. Re: Problems with AMD Graphics, AE and Element3D
              Mylenium Most Valuable Participant

              You disable the intel stuff in the BIOS/ EFI.

               

              Mylenium

              • 4. Re: Problems with AMD Graphics, AE and Element3D
                felystar Level 1

                Unfortunately that option is not available in my BIOS, I've just updated it to the latest version available and the only option about it is to disable switchable graphics which disables the discrete one (AMD). I've set in all preferences to use the AMD one but the intel one is still in use and After Effects it's like before, not letting my use OpenGL properly.

                 

                I can't disable Intel graphics as I've found out, I can just select which graphic to use in which aplication... I've reinstalled the drivers provided by HP but it doesn't work either

                 

                Maybe this helps:

                Microsoft Windows [Versión 6.3.9600]

                (c) 2013 Microsoft Corporation. Todos los derechos reservados.

                 

                 

                C:\Archivos de programa\Adobe\Adobe After Effects CC 2015\Support Files>GPUSniff

                er.exe

                --- OpenGL Info ---

                Vendor: ATI Technologies Inc.

                Renderer: AMD Radeon HD 8750M

                OpenGL Version: 4.5.13401 Compatibility Profile Context 15.201.1301.0 15.201.130

                1.0

                GLSL Version: 4.40

                Monitors: 1

                Monitor 0 properties -

                   Size: (0, 0, 1366, 768)

                   Max texture size: 16384

                   Supports non-power of two: 1

                   Shaders 444: 1

                   Shaders 422: 1

                   Shaders 420: 1

                 

                 

                 

                 

                --- GPU Computation Info ---

                   Support not enabled.

                 

                 

                C:\Archivos de programa\Adobe\Adobe After Effects CC 2015\Support Files>AEGPUSni

                ffer.exe

                LoadLibrary "n" failed!

                LoadLibrary "n" failed!

                Using DXGI: Device: "Intel(R) HD Graphics 4000" has dedicated video RAM (MB): 10

                72 and has shared video RAM (MB): 1972 (Total: 3044 MB)

                Vendor string:    ATI Technologies Inc.

                Renderer string:  AMD Radeon HD 8750M

                Version string:   3.0.13401 Compatibility Profile Context 15.201.1301.0

                OpenGL Version:   3.0

                Shader Model:     4.0

                Has NPOT support: TRUE

                Has Framebuffer Object Extension support: TRUE

                Has Shading Language support: TRUE

                Started compilation of GLSL shaders

                Successfully finished compilation of GLSL shaders

                Has Shader Model 4 support: TRUE

                Return code: 3

                 

                 

                C:\Archivos de programa\Adobe\Adobe After Effects CC 2015\Support Files>

                 

                Inside of Previews in After Effects only OpenGL Version 3.0.13401 is shown. I have everything is needed but I can't use the Hardware Acceleration...