5 Replies Latest reply on Jun 22, 2017 7:55 AM by abhjha

    Could not determine Apache connector version

    evanc19799295

      I'm trying to execute wsconfig on the following platform:

       

      Ubuntu 14.04

      Apache 2.4.7

      Coldfusion 2016

       

      When I run:

       

      sudo /opt/coldfusion10/cfusion/runtime/bin/wsconfig -ws Apache -dir /etc/apache2/conf-available -bin /usr/sbin/apache2 -script /usr/sbin/apache2ctl -v

       

      Ignore the coldfusion10 part in the path. I just haven't updated directory names just yet in my chef/vagrant cookbook/recipes/whatever files.

       

      I get:

       

      command line: -ws Apache -dir /etc/apache2/conf-available -bin /usr/sbin/apache2 -script /usr/sbin/apache2ctl -v

      Using Apache binary /usr/sbin/apache2

      Could not determine Apache connector version.

      Check that the Apache binary path /usr/sbin/apache2 is correct.

       

      When I run:

       

      which apache2

       

      I get:

       

      /usr/sbin/apache2

       

      When I run:

       

      which apache2ctl

       

      I get:

       

      /usr/sbin/apache2ctl

       

      According to this https://helpx.adobe.com/pdf/coldfusion2016-support-matrix.pdf Apache 2.4.X is supported on Linux 64-bit.

       

      What am I missing? Any help is appreciated. Thanks.