2 Replies Latest reply on Jul 28, 2016 11:06 PM by Willi Adelberger

    Reversed apostrophe and quotation marks misbehaving

    joet082964 Level 3

      On a document I received from my German counterpart, the apostrophes are backwards and the quotation marks are on the baseline. See the last sample, below.

      If I start a new document using that same font, it works properly. If I copy and paste the text to a new document, it's messed up, which made me think it's a style issue.  The only thing I noticed in the applied paragraph style is the dictionary, which was set to German Reform 2006.  I changed the dictionary to English USA, but the problem remains.

       

      Any idea what is causing this?

       

        • 1. Re: Reversed apostrophe and quotation marks misbehaving
          Peter Spier Most Valuable Participant (Moderator)

          Dictionary setting has no effect on language, which is a character-level attribute.

           

          You are correct, though, that the assigned language affects the style of quotation marks and other punctuation. I believe to only way to change those marks now would be to select the text, change the assigned language (in the control panel, character panel, or the style definition if there is a style applied), then use Find/Change to replace quotes with the same marks, or you could go through and retype them manually after changing the language.

          • 2. Re: Reversed apostrophe and quotation marks misbehaving
            Willi Adelberger Most Valuable Participant
            1. You have to set up in your paragraph and character styles ALWAYS the correct language (the language of the text, not the User Interface).
            2. In Preferences > Dictionaries you have to set up for each language the correct apostrophes, as there are huge difference between languages:
              1. Englisch US: “…”, ‘…’
              2. German AT & DE: „…“, ,…‘ or »…«, ›…‹
              3. German CH: «…», ‹…›
              4. French FR: «…», ‹…›
              5. Danish DK: „…“, ,…‘

            InDesign chooses during writing and importing automatically, if typographic quotes are turned on, the language's correct apostrophes.

            But it is also possible to correct it to replace and find " with ", and ' with ' it will replace everywhere the correct apostrophe.

            If you have text, like code, where you need straight apostrophes, you have to use a paragraph style with no language.

             

            But in your last screen shot is also an error with Billy’s, the missing letter sign goes to the wrong direction, it should be similar like a number 9, but it looks in the wrong direction.