4 Replies Latest reply on Feb 13, 2017 1:40 PM by markw1879624

    Can't open acsm books downloaded from library

    brucec_gorge

      Titles appear to download correctly but can't be opened.  Non-protected documents such as the getting started guide open fine.

      Have tried both 4.5.1.139278 and 3.0.1.91394, to no avail.  I've also tried resetting my adobe id password.

       

      Redownloading then dragging onto the app used to give "INTERNAL ERROR", but now gives "Error check activation" on 3.0, 4.5.1 hangs after the "Fulfilling..." dialog "Downloading Content..." bar completes.

       

      After restarting the app, the books show up, and show as Licensed and Viewable on any device, Copying and Printing not allowed.  Opening a book hangs Adobe Digital Editions 4.5.1

       

      (Note that this is all before this evening's Adobe outage.)

       

      Any thoughts?

        • 1. Re: Can't open acsm books downloaded from library
          Nanaky Level 5

          Windows:

           

              Close all applications.

              Choose Start > Run.

              In the Open text box, type regedit and then press Enter. The Registry Editor opens.

              In the left pane of the Registry Editor, locate the following registry key: HKEY_CURRENT_USER\Software\Adobe\Adept

              Select the Adept key.

              Choose File > Export.

              In the Export Registry File dialog box, select Selected Branch under Export Range. Enter a name and location for the backup registry key, and then click Save.

              Right-click the Adept key and choose Delete.

              In the Confirm Key Delete dialog, click OK.

              Close the Registry Editor.

              Open Adobe Digital Editions and reauthorize.

           

          Macintosh:

           

              quit Adobe Digital Editions.

              Navigate to /Users//Library/Application Support/Adobe/Digital Editions and drag the activation.dat file to the trash.

              If you are using 10.7, see https://helpx.adobe.com/x-productkb/global/access-hidden-user-library-files.html

              Open Adobe Digital Editions and reauthorize.

          • 2. Re: Can't open acsm books downloaded from library
            brucec_gorge Level 1

            Thanks for the suggestion, but there was no change in the behavior.  I followed Nanaky's steps, then dragged a recently borrowed item from my downloads folder onto Adobe Digital Editions.  The Fulfilling dialog box appeared, but after filling the "Downloading Content..." dialog box, the application hung.  After restarting Adobe Digital Editions, the title shows up, saying it's licensed, with viewing allowed on any device; copying and Printing not allowed.  Attempting to read it results in another hang.

            • 4. Re: Can't open acsm books downloaded from library
              markw1879624

              I am having exactly the same problem, and it appears to me that the problem is with ADE trying to unlock the document with something from the Internet (probably an operation with the license key) after it has already been authorised to download it. Instead of timing out with an error message it just hangs. Perhaps because of a problem with credentials, this does not happen.

               

              Other documents continue to open fine

               

              Therefore purging the adept key has no effect.

               

              An unfortunate side effect of this problem is that ADE also seems to associate the failed ACSM file with the Adobe ID, so when you connect to the Internet ADE downloads all the incomplete ACSM files which you may not necessarily want, and (because it is associated with the Adobe ID) and not ADE you cannot delete, because if you do they will just come back.


              So you get two bugs for the price of one!

               

               

              This is all supposition of course, but it seems to fit the facts.