3 Replies Latest reply on Aug 3, 2016 5:04 AM by Peter Spier

    InDesign - Datamerge skips and re-orders data

    eguillemette-pinestatet

      Hi everyone. I'm having a bit of trouble with a feature of InDesign that I have a lot of experience with, and I'd appreciate a second pair of eyes to possibly spot something ridiculously simple that I'm missing.

       

      I have a lot of experience with DataMerge, and a particular template that has been used several dozen times in the past six months has suddenly been acting wonky. It seems to skip the first 11 rows or so of the .csv file, repeat the next line 10 times, continue with the next few rows, then repeat the same line from before another 40 or so times.

       

      There are no hidden columns/rows in the CSV file. And just to make sure, I've re-created the file three different times, even copy/pasting the data into a fresh workbook. No dice. And I can confirm that I'm using the correct CSV file every time.

       

      Under the datamerge options, it is set to "All Records", and "Remove Blank Lines for Empty Fields" is left unchecked. Weirdly enough, the Preview Multiple Record Layout lays everything out correctly. As does the single record preview. But as soon as I actually merge, it trips over itself.

       

      In the interests of being as thorough as possible, below are the screenshots of the step by step along the way:

       

      1. The CSV file. Everything is in alphabetical order, starting with "ALAMOS". Only 5 "LIBERTY CREEK" entries:

      http://ethanguillemette.com/Work/Datamerge9.jpg

      2. The correct CSV file is selected, and the data holders are all properly filled.

      http://ethanguillemette.com/Work/Datamerge1.jpg

      3. Preview shows the first tag being "ALAMOS MALBEC".

      http://ethanguillemette.com/Work/Datamerge2.jpg

      4. "All Records" is selected.

      http://ethanguillemette.com/Work/Datamerge3.jpg

      5. Multiple Record Layout options (not sure if anything here is relevant)

      http://ethanguillemette.com/Work/Datamerge4.jpg

      6. "Remove Blank Lines for Empty Fields" is unchecked.

      http://ethanguillemette.com/Work/Datamerge5.jpg

      7. "Preview Multiple Record Layout shows correct data.

      http://ethanguillemette.com/Work/Datamerge6.jpg

      8. Once datamerged, first tag is "LIBERTY CREEK MERLOT" (should be "ALAMOS MALBEC"). Continues "LIBERTY CREEK MERLOT" for 11 entries.

      http://ethanguillemette.com/Work/Datamerge7.jpg

      9. After 7 correct entries, it repeats "LIBERTY CREEK MERLOT" for several pages until the end of the document.

      http://ethanguillemette.com/Work/Datamerge8.jpg

       

      I've tried the same template with other CSV files, and similarly skips rows, but not the same one. Additionally, it does the same thing on two different computers.

       

      Am I missed something obvious here? Or is this really broken? It's a barebones template that I could recreate in my sleep, but I'm worried that there's something I don't know I'm doing that is messing things up.

       

      Message was edited by: Ethan Guillemette (added the bit about it not working with other CSV files and other computers)