4 Replies Latest reply on Aug 7, 2016 4:52 AM by VectorP

    erreur mise à jour cli-6.3.0

    leberte76119187

      Bonjour,

       

      Mon application marche très bien jusqu'a la 3.7.7 (phonegap build) mais des que je passeaux versions cli-xxx juqu'à la version cli-6.3.0 cela me met une ''erreur réseau s'est produite (http://www.mon-nom-application.fr/)''

       

      Merci pour votre aide

        • 1. Re: erreur mise à jour cli-6.3.0
          kerrishotts Adobe Community Professional

          Google Translate to English:

           

          Hello,   My application works fine until the 3.7.7 ( build phonegap ) but I Passeaux xxx cli- cli- versions juqu'à the 6.3.0 release that makes me a ' network error occurred ( http: //www.mon-nom-application.fr/ ) ''   Thank you for your help

           

          My (naive) interpretation:

           

          Hello, my application worked fine with 3.7.7 (using PhoneGap Build). But when I build with 6.3.0, I receive a "network error occurred (http://www.mon-nom-application.fr/)". Thanks for your help.

           

          Apologies if I missed anything there.

           

          Also: I'm moving to the PGB forum.

          • 2. Re: erreur mise à jour cli-6.3.0
            VectorP Level 4

            PGB 3.7.7 never existed.

            But anyway, one of the significant changes towards cli-999 was whitelisting. My guess is that you have not included the whitelist plugin from npm.

            See Access Elements | PhoneGap Docs

            and GitHub - apache/cordova-plugin-whitelist: Mirror of Apache Cordova plugin whitelist

             

            I suppose you will need to make further changes, like including the splashscreen plugin and using the syntax without :gap namespace.

            In order to understand what has changed in the past, oh, 15 months, this blog would be a good start:

            PhoneGap Build

            • 3. Re: erreur mise à jour cli-6.3.0
              leberte76119187 Level 1

              Je débute et je comprend pas tout le fonctionnement voici mon fichier XLM, merci de votre aide :

               

              <?xml version='1.0' encoding='utf-8'?>

              <widget id="fr.lebert-emmanuel.app" versionCode="6" version="1.0.3" xmlns="http://www.w3.org/ns/widgets" xmlns:gap="http://phonegap.com/ns/1.0">

                 

                  <name>CRONY</name>

                  <description>Réseau Social Multi-Sports</description>

                  <author email="contact@crony.fr" href="http://www.crony.fr">LEBERT Emmanuel</author>

               

                  <preference name="phonegap-version" value="cli-6.3.0" />

                  <feature name="http://api.phonegap.com/1.0/device" />

                 

                  <preference name="orientation"                value="portrait" />       <!-- all: default means both landscape and portrait are enabled -->

                 

                  <gap:plugin name="org.apache.cordova.device" />

                  <gap:plugin name="org.apache.cordova.camera" />

                  <gap:plugin name="org.apache.cordova.media-capture" />

                  <gap:plugin name="org.apache.cordova.file" />

                  <gap:plugin name="org.apache.cordova.file-transfer" />

                  <gap:plugin name="org.apache.cordova.splashscreen" />

                  <gap:plugin name="org.apache.cordova.contacts" />

                  <gap:plugin name="org.apache.cordova.geolocation" />

                  <gap:plugin name="org.apache.cordova.inappbrowser" />

                  <gap:plugin name="org.apache.cordova.dialogs" />

                  <gap:plugin name="org.apache.cordova.vibration" />

                  <gap:plugin name="org.apache.cordova.network-information" />

                  <gap:plugin name="com.simplec.plugins.localnotification" />

               

                  <icon src="icon.png" />

                 

                  <icon src="res/icons/ios/Icon.png" gap:platform="ios" width="57" height="57" />

                  <icon src="res/icons/ios/Icon@2x.png" gap:platform="ios" width="114" height="114" />   

                  <icon src="res/icons/ios/Icon-72.png" gap:platform="ios" width="72" height="72" />

                  <icon src="res/icons/ios/Icon-72@2x.png" gap:platform="ios" width="144" height="144" />

               

                  <icon src="res/icons/android/drawable-ldpi/Icon.png" gap:platform="android" gap:density="ldpi" />

                  <icon src="res/icons/android/drawable-mdpi/Icon.png" gap:platform="android" gap:density="mdpi" />

                  <icon src="res/icons/android/drawable-hdpi/Icon.png" gap:platform="android" gap:density="hdpi" />

                  <icon src="res/icons/android/drawable-xdpi/Icon.png" gap:platform="android" gap:density="xhdpi" />

                 

                  <gap:splash src="splash.png" />

                 

                  <gap:splash src="res/screen/android/drawable-ldpi/splash.png"  gap:platform="android" gap:density="ldpi" />

                  <gap:splash src="res/screen/android/drawable-mdpi/splash.png"  gap:platform="android" gap:density="mdpi" />

                  <gap:splash src="res/screen/android/drawable-hdpi/splash.png"  gap:platform="android" gap:density="hdpi" />

                  <gap:splash src="res/screen/android/drawable-xdpi/splash.png" gap:platform="android" gap:density="xhdpi" />

                 

                  <gap:splash src="res/screen/ios/Default.png" gap:platform="ios" width="320" height="480" />

                  <gap:splash src="res/screen/ios/Default@2x.png" gap:platform="ios" width="680" height="960" />

                  <gap:splash src="res/screen/ios/Deafult-568h-2x.png" gap:platform="ios" width="640" height="1136" />

               

                  <content src="http://www.crony.fr" />

                  <access origin="*" subdomains="true" />

              </widget>

              • 4. Re: erreur mise à jour cli-6.3.0
                VectorP Level 4

                Here is my feedback:

                 

                1. Replace all plugins by the latest versions from npm. Be aware that they are named differently, usually cordova-plugin-xxxx.

                See Plugins | PhoneGap Docs

                Make sure you use the <plugin> syntax, without the :gap namespace

                Find them here: Plugin Search - Apache Cordova

                 

                2. Remove all feature elements, since they are obsolete

                 

                3. Add the splashscreen plugin from npm

                cordova-plugin-splashscreen

                 

                4. Add the whitelist plugin from npm

                Add 'allow-navigation' rules if necessary.

                cordova-plugin-whitelist

                 

                5. For icons and splashes, use the syntax without :gap namespace.

                See Icons and Splash | PhoneGap Docs

                 

                6. Add the larger dimensions of splashes. For Android: xxhdpi and xxxhdpi.

                For iOS, see the Apple iOS documentation on 'launch images'

                 

                7. About your content element: do you really just want to display a website in your webview component? If so, are you aware that Google and Apple may reject your app for that reason?