2 Replies Latest reply on Aug 10, 2016 1:24 PM by Bob Somrak

    Lightroom 6.6.1 is going further backwards here

    AndyHewitt

      I recently aborted LR6.6 (I use the standalone paid for version) and reverted to 6.5.1 due to a few issues with lens profiles and some editing tools. I have tried 6.6.1 now, but they seem even worse now.

       

      I see this mainly with Nikon lenses, using a D5100 body. The 18-135 lens has no built in profile as standard, and it does not show a 'using built in profile' if deselected, only an 'unable to load profile' error. I have downloaded a suitable profile using the lens profile dowloaded tool, which seems to work OK, although sometimes it auto selects, other times I have to 'kick' it into action.

       

      I also use a Nikon 55-300 lens, which does have an Adobe profile as standard. However, using LR6.6.1 (or 6.6), I see that it randomly leaves the lens selection blank, and does not apply the lens corrections. If I click the tick off and on again, it then selects the lens profile (I can also reactivate it by resetting edits, or changing the profile from Default to Auto, or vice versa).

       

      In both those cases there seems to be no pattern, it can happen to a bunch of images in the middle of a set, or a few, or one.

       

      I have tried this with and without GPU acceleration (that's another issue in itself), and also tried completely reinstalling, all to no avail. Reverting back to 6.5.1 again is the only fix.

       

      Again in LR6.6.1 I get multiple UI glitches (although this is a slight improvement over 6.6) when using the GPU acceleration, but really poor performance if disabled. In LR 6.5.1 I can use the GPU acceleration without any issues, or switch it off without too much performance hit.

       

      It just seems to me that each release now is sending LR backwards in terms of usability, and the latest batch of issues seem to originate with the splitting up and redesign of the Lens Corrections tab. Perhaps some bugs have been introduced because of that (remember the redesigned Import box?).