1 Reply Latest reply on Apr 30, 2006 7:51 AM by Newsgroup_User

    using load movie and load variable

    batgirl_Sa
      Ok i am having a problem with my movie... when i test it using test movie it is fine but when i preview in HTML or run the SWF on it own i am having a problem... and i spotted the items i am having a problem with but problem is i dont know why.



      i am loading a movie dynamically in my main movie using load movie

      loadMovie("menu.swf",_root.i_dress2.i_content);


      and in the actual movie menu.SWF i am loading a text dynamically using loadvariable... but i am actually loading it into the movie that has already been loaded into my main movie... maybe it i will make sense when you see my line of script that is in the menu.sef movie....


      loadVariables("menu.txt",_root.i_dress2.i_content.arg.maskedText.scrollpage);


      so i guess it is like i am loadingthe txt into the text file after it is loaded into the main movei so that is why it is referring ot the text field that way...

      anyway it works fine when i go thorugh test movie but when i preview in HTML the text doenst come out...

      am i doing this thewrong way.? is there something i am missing?

      Thanks...any help will be appreciated!!

        • 1. Re: using load movie and load variable
          Level 7
          You may be hitting a Flash 8 security issue that you cannot load external
          data using file:////path_to_your_movie/youmoviehtml in a web browser. You
          may need to use http://thedomain.com/yourmovie.html.



          --
          Lon Hosford
          www.lonhosford.com
          May many happy bits flow your way!
          "batgirl_Sa" <webforumsuser@macromedia.com> wrote in message
          news:e2v04c$lq$1@forums.macromedia.com...
          Ok i am having a problem with my movie... when i test it using test movie
          it
          is fine but when i preview in HTML or run the SWF on it own i am having a
          problem... and i spotted the items i am having a problem with but problem is
          i
          dont know why.



          i am loading a movie dynamically in my main movie using load movie

          loadMovie("menu.swf",_root.i_dress2.i_content);


          and in the actual movie menu.SWF i am loading a text dynamically using
          loadvariable... but i am actually loading it into the movie that has already
          been loaded into my main movie... maybe it i will make sense when you see my
          line of script that is in the menu.sef movie....


          loadVariables("menu.txt",_root.i_dress2.i_content.arg.maskedText.scrollpage); so i guess it is like i am loadingthe txt into the text file after it isloaded into the main movei so that is why it is referring ot the text fieldthat way... anyway it works fine when i go thorugh test movie but when i preview inHTMLthe text doenst come out... am i doing this thewrong way.? is there something i am missing? Thanks...any help will be appreciated!!