4 Replies Latest reply on Aug 12, 2016 12:21 AM by lowx99828288

    Signed APK incompatible on the Play Store

    lowx99828288 Level 1

      Hi all, I am an amateur on this so please pardon my bad technical terms

      I am using PhoneGap Build cli-6.3.0 (4.2.0 / 5.2.1 / 4.4.1)

       

      Apparently i have submitted a html zip file (from Construct 2) to the build server and had it signed and according to the log everything was signed without a problem.

      However when I try to install it on my phone it says (X App not Installed)

      I thought it was some security issues but I went ahead and submitted onto the play store.

      Here is the problem, Play Store accepted my apk without a problem however my app was incompatible for devices

       

      May i know if there are any workaround for this? Thanks!

       

       

        • 1. Re: Signed APK incompatible on the Play Store
          Chris W. Griffith Adobe Community Professional

          Depending which plugins you use, you may have some incompatible devices. I once used an Android device that did not have an accelerometer.

           

          If you use Crosswalk as your replacement webview and did not upload both builds, you also have a list of incompatible devices.

           

          Also if you target specific Android SDKs, that can exclude devices as well.

           

          Chris

          • 2. Re: Signed APK incompatible on the Play Store
            lowx99828288 Level 1

            Apparently the plugins I have used are compatible to all devices (i think)

            here are the pictures

            and yes i use crosswalk1.PNGCapture.PNG

             

            and lastly this is my config file

             

            <?xml version="1.0" encoding="UTF-8"?>

            <widget xmlns="http://www.w3.org/ns/widgets" xmlns:gap="http://phonegap.com/ns/1.0" id="com.awltims.awltims" version="1.0.1">

             

             

              <name>StandardSim</name>

              <description>the standardizer simulator</description>

              <author></author>

             

             

              <icon src="icon-128.png" width="128" height="128" />

              <icon src="icon-256.png" width="256" height="256" gap:role="default" />

             

             

              <preference name="permissions" value="none"/>

              <preference name="android-targetSdkVersion" value="23" />

             

             

              <feature name="http://api.phonegap.com/1.0/network"/>

             

             

              <preference name="orientation" value="landscape" />

              <preference name="fullscreen" value="true" />

              <gap:config-file platform="ios" parent="UIStatusBarHidden"><true/></gap:config-file>

              <gap:config-file platform="ios" parent="UIViewControllerBasedStatusBarAppearance"><false/></gap:config-file>

             

             

              <preference name="deployment-target" value="8.0" />

              <preference name="android-minSdkVersion" value="14" />

              <plugin name="cordova-plugin-crosswalk-webview" source="npm" />

             

             

              <plugin name="cordova-plugin-wkwebview-engine" />

              <plugin name="cordova-plugin-file" />

              <plugin name="cordova-plugin-httpd" />

             

             

              <plugin name="cordova-plugin-whitelist" source="npm" />

              <access origin="*" />

             

             

              <!-- Optional splash screen image, e.g.: -->

              <!-- <gap:splash src="splash.png" width="1024" height="768" /> -->

             

             

            </widget>

            • 3. Re: Signed APK incompatible on the Play Store
              joe_bowser Adobe Employee (Admin)

              Crosswalk recently dropped support for Ice Cream Sandwich, which is Android 4.0.  It would be helpful to know what device you are using, as well as what version of Android you are running on this device.  Without that information, we can't really tell what's happening with your APK.  The play store does have some very good tools to tell you which devices are supported and why your APK doesn't support all devices.

              • 4. Re: Signed APK incompatible on the Play Store
                lowx99828288 Level 1

                Thank you! I have changed my minimum android version to Lollipop 5.0+ (WebView) and phonegap build gave me a release that can be installed on my Marshmallow phone