1 Reply Latest reply on Aug 15, 2016 11:31 PM by Jashn

    Device not recognised

    Jashn

      Hi there, I have a Sony PRS-650 I used to use on my old Windows 7 laptop, and recently got a new Windows 10 laptop. I was able to download ADE onto the new computer and authorize it, but when I plug my e-reader into the computer, it doesn't show up in ADE. My computer does recognise the device, however, and the drive for the e-reader is visible on the 'this pc' page. I've tried connecting the device both before and after ADE was opened with no success. Can anyone give some advice on how to fix this? Thanks in advance.

        • 1. Re: Device not recognised
          Jashn Level 1

          I downloaded Calibre, out of curiosity, and that programme does read my device correctly. I double-checked, and my device is listed on the list of compatible devices with ADE, and as I mentioned above, I've used it without problem till I tried to use it on my new laptop. I don't understand what the problem is. Could anyone please help? Thanks.