5 Replies Latest reply on Aug 18, 2016 9:23 AM by DanTull

    File doesn't exist

    Paulskii7

      Hi,

       

      So I just downloaded After Effects for Mac(El Capitan) and when I try to launch Adobe Character Animator, in trial mode, I get an error like this, "File doesn't exist: /Users/<useraccount>/Documents/Adobe/Character Animator/Preview 4/Getting Started Project [Preview 4]/Ch Data/temp.noindex/compiler/BehaviorParamBootstrap.js"

       

      I clicked OK then I noticed something like this in the Behaviors Panel:

       

      14037385_10154202365617819_43716313_o.jpg

       

      When I try to click the small '+' icon, nothing shows up.. Then I tried loading the Project again by going to the Welcome Tab and clicking "Start Here!". It loaded the Project and fixed the Behaviors, I can now see the Dangle, Face, Lip Sync, etc.., but I got the same error as the above only this time, it's not looking for the BehaviorParamBootstrap javascript file. It's looking for a "bootstrap.js" file. When I try to check the directory, I can see the bootstrap.js file is there. I can't use Character Animator properly as the error will prompt every time I select something in the timeline (Scene).

       

      I've already tried reinstalling AE for three times, (Uninstall, Restart Machine, Install) and still getting the same problem.

       

      Also, I don't think the reason is because I'm using a Trial version. I've installed AE (Trial Version) in my PC(WIndows 7) as well and Character Animator is working fine.

       

      Any thoughts regarding this issue? Thanks.

       

      Paul

        • 1. Re: File doesn't exist
          DanTull Adobe Employee

          Does your error message literally include <useraccount> in the text or did you redact that? It's totally fine if you did, but for me that message (I recreated a similar condition artificially) contains my actual username so if yours actually says <useraccount> it might be a clue as to the nature of the failure.

           

          Thanks,

          Dan Tull

          1 person found this helpful
          • 2. Re: File doesn't exist
            Paulskii7 Level 1

            Hi Dan!

             

            Thanks for the reply. I redacted it.

             

            Paul

            • 3. Re: File doesn't exist
              Paulskii7 Level 1

              Problem Solved!

               

              I open Ch Animator and the error prompted again. I read every line of the directory and I found the culprit. I overlooked the user account. The user account that Ch Animator error is giving me is not the same as the User account in my Mac. Some characters are missing at the end. Say for example if my user account is "JohnDoeAdminAccount", the error is giving me the directory, "Users/JohnDoeAdminAcco/...". So I figured maybe there is a limit to how many characters a User Account in a Mac should have. Or maybe Ch Animator is programmed that way. Not sure. And that is why ch animator could not locate the bootstrap.js file because it's trying to locate it in a directory that doesn't even exist.

               

              So I created a new Admin Account with less characters or shorter name, Loaded Character Animator, and the Error is gone.

               

              Thanks. 

              • 4. Re: File doesn't exist
                DanTull Adobe Employee

                Interesting, thanks for posting back. I had a few theories about how the path could wind up being different on disk so it would be written successfully but then fail to be found when other code went to read it. One hypothesis was that it was some text encoding conversion corner case due to filesystem paths using a different encoding than the code generating the path. I was about to ask if you could tell me your account name because the rest of the path seemed totally normal.

                 

                I'll see if I can recreate this condition on my machine to determine if there's a bug on our side that we need to fix.

                 

                Thanks!

                Dan Tull

                • 5. Re: File doesn't exist
                  DanTull Adobe Employee

                  Further analysis based on a tip from Paul: the key detail here appears to be that Character Animator cannot open a path which contains an element that ends with a period. An odd case to be sure but still a bug. I'll file that internally.

                   

                  Thanks, Paul!