1 Reply Latest reply on Aug 31, 2016 12:05 PM by andersborglund

    It is forbidden to downgrade devices which previously used M permissions (target SDK 23 and above)

    thatsmekaustubh

      Hello I am using Phonegap Build (online Tool) facing ! issue

      Here's the error message :

      This configuration cannot be published for the following reason(s): It is forbidden to downgrade devices which previously used M permissions (target SDK 23 and above) to APKs which use old style permissions (target SDK 22 and below). This occurs in the change from version 12 (target SDK 23) to version 45 (target SDK 0). It is forbidden to downgrade devices which previously used M permissions (target SDK 23 and above) to APKs which use old style permissions (target SDK 22 and below). This occurs in the change from version 12 (target SDK 23) to version 45 (target SDK 0). Version 44 is not served to any device configuration: all devices that might receive version 44 would receive version 45. Some devices are eligible to run multiple APKs. In such a scenario, the device will receive the APK with the higher version code.

      For 44 I have set following in config.xml

      <preference name="android-minSdkVersion" value="23" />

      For 45 I have set following in config.xml

      <preference name="android-minSdkVersion" value="16" />

      Please help