12 Replies Latest reply on Sep 6, 2016 10:13 AM by SpokaneJim

    LR6: search for image in catalog yields no results, but import of same image says it's in catalog

    SpokaneJim

      Symptom:  Using LR6, I imported all images from a folder, but they did not appear in my LR catalog when I look at that folder from within LR's library.  I also did not get any error messages after this import.  Searching my entire LR catalog for any of the images I attempted to import also yields no results.... in short it looks like the images never made it into LR's catalog.  However when I try to import these images again using LR, I get the "This appears to be a duplicate of another photo already in the catalog" when I hover my cursor over the image from the import window within LR.

       

      Seems like I had a temporary glitch when importing.  During my initial Import I had two drives with the same name when I tried to import the images initially... one had a small subset of all the folders on this drive, the other had all of the folders.  I had never seen this before.  I should have stopped and reset my computer and restarted LR to clean this anomaly before proceeding with my import.  (Which did work later.)  I wasn't thinking and proceeded importing from the drive that seemed to have all of my folders and images on it.  After import my folder within my LR library was empty... no images were shown on this folder's LR library screen.  Confused I simply tried to import the images again, but cannot because LR's catalog seems to think they are there, even though they are not visible in my LR library.  There are no images to select in my library to reassign their source to.  After some quick testing I am successful at renaming some of the same images and I can import successfully to the same source folder to the same destination folder in my LR library.  All of my LR functions seem to be functioning normally for all of my existing cataloged images and any new images I'd like to import that have names different from the "problem images".

       

      I'm wondering what my courses of action are from this point?  I could easily rename my images and import them... often a big LR no-no I know, but with my naming convention these image names will not be repeated again.  I honestly don't know how two drives of the same name appeared in the initial LR import, and after several years of using LR I've never seen it before, and I've made no changes to my hardware setup in the last four years.  However I can't figure out how I could delete these images from my catalog so I can import then when they can't be found in my catalog to begin with.

       

      Perhaps now complicating things, using LR I deleted the folder that had contains the images I cannot see in LR.  I then placed the same source images in another similar, but newly named folder.  As explained above, importing these same images from the new folder is not allowed because the image names are still the same.  Thus I don't have the "problem" folder in my LR library to work with anymore.