3 Replies Latest reply on Sep 12, 2016 10:08 AM by kerrishotts

    android AdMob SDK deprecation, i need help to undestand which version i am running

    piergiorgiop12572091 Level 1

      Hi to all,

      my app is currelty using this plugin to implement ads by admob:

       

      com-admob-plugin-pgp

       

      this is the manifest of the plugin:

       

      <?xml version="1.0" encoding="UTF-8"?>

      <plugin xmlns="http://apache.org/cordova/ns/plugins/1.0"

              xmlns:android="http://schemas.android.com/apk/res/android"

              id="com-admob-plugin-pgp"

              version="1.0.1">

          <name>Admob Plugin PGP</name>

          <keywords></keywords>

          <description>Basato sulla versione 5.4.0 di com-admob-plugin</description>

          <license>Apache 2.0 License</license>

          <repo>https://github.com/admob-google/admob-cordova</repo>

        <issue>https://github.com/admob-google/admob-cordova/issues</issue>

          <engines>

              <engine name="cordova" version=">=3.0" />

          </engines>

          <js-module src="www/admob.js" name="admob">

              <clobbers target="window.admob"/>

          </js-module>

          <platform name="android">

              <config-file target="res/xml/config.xml" parent="/*">

                  <feature name="admob" >

                      <param name="android-package" value="com.admob.cordova.plugin.AdmobAdPlugin"/>

                  </feature>

              </config-file>

              <config-file target="AndroidManifest.xml" parent="/manifest/application">

                 <!--<meta-data  android:name="com.google.android.gms.version"   android:value="8115000"/>-->

        <activity  android:name="com.google.android.gms.ads.AdActivity"  android:configChanges="keyboard|keyboardHidden|orientation|screenLayout|uiMode|screenSize |smallestScreenSize"/>

              </config-file>

              <config-file target="AndroidManifest.xml" parent="/*">

                   <uses-permission android:name="android.permission.INTERNET"/>

           <uses-permission android:name="android.permission.ACCESS_NETWORK_STATE"/>

           <uses-permission android:name="android.permission.ACCESS_WIFI_STATE"/>

              </config-file>

             

              <source-file src="src/android/libs/admobadplugin.jar" target-dir="libs/"/>

              <!--<source-file src="src/android/libs/google-play-services.jar" target-dir="libs/"/>-->

              <framework src="com.google.android.gms:play-services-ads:+" />

       

       

          </platform>

          <platform name="ios">

              <config-file target="config.xml" parent="/*">

                  <feature name="admob">

                      <param name="ios-package" value="AdmobAdPlugin"/>

                  </feature>

              </config-file>

              <source-file  src="src/ios/AdmobAdPlugin.m"/>

              <header-file  src="src/ios/AdmobAdPlugin.h"/>

              <framework src="src/ios/AdmobAPI.framework" custom="true"/>

           <framework src="EventKit.framework"/>

              <framework src="EventKitUI.framework"/>

              <framework src="StoreKit.framework"/>

              <framework src="AdSupport.framework"/>

              <framework src="MessageUI.framework"/>

              <framework src="AVFoundation.framework"/>

              <framework src="Foundation.framework"/>

              <framework src="UIKit.framework"/>

              <framework src="CoreGraphics.framework"/>

              <framework src="SystemConfiguration.framework"/>

              <framework src="AudioToolbox.framework"/>

          </platform>

      </plugin>

       

      how can i know which version of admob SDK (or google play service) i'm running with it?

       

      Thanks